I have a NAS based on Linux, but the root password is kept secret by the manufacturer.

Now to reset the password I am trying to mount the disk to my local linux computer. All of the files are present and changing files does affect the system, so I this is the right disk an partition to use.

Next step would be to chroot on the disk and simply do a passwd to change the password for root (since I am already root on the local linux computer). But there is a big problem:

chroot to the disk is not possible because its architecture is ARM, which differs from my x86 linux computer.

I heard from Qemu and its ability to emulate different architectures. Can I emulate ARM and use ARMEL/Debian Linux inside this Qemu VM to mount the NAS Hard Disk and make a successful chroot?

Is it possible or are there even better solutions. This constellation was pretty rare and badly documented in the world wide web.

Thank you in advance.

This Question is obsolete, since the main problem was solved on another way. Should this post be deleted or kept for historical reasons?

  • What is your NAS's make and model? They seriously don't give you root access? – terdon May 16 '13 at 11:04
  • It is a Seagate BlackArmor 400 (Identical Software to the other BlackArmors). There are many resources for the SHASTA Board inside, but the root password has been changed and so the resources are outdated. Also I don't want to downgrade to a 2 year older Firmware. – SiLeX May 16 '13 at 11:36

This is probably a useful starting point, because it includes instructions for dealing with mirrored drives: http://forums.seagate.com/t5/BlackArmor-NAS-Network-Storage/SSH-root-access-for-BlackArmor-NAS/td-p/108264

A quick and dirty solution if the NAS uses a standard /etc/passwd and /etc/shadow files (this depends on its /etc/nsswitch.conf as well as its pam configuration in /etc/pam.conf and /etc/pam.d/*), is to simply delete the root password there: assuming you've mounted the NAS root partition as /mnt, then edit /mnt/etc/shadow to clear the password field (change a line starting root:<hashed_password>:... to root::....

Remember that you absolutely must log into the NAS, become root (if you get a password prompt, just hit return) and set a new password before reattaching it to a shared network (let alone the internet), because root has an empty password!

| improve this answer | |
  • Thanks! That's a nice starting point and a different point of view. nsswitch.conf is set to look in the files, so this should be right. pam doesn't exist. Unforunately emptying the root password did not work. Dropbear SSH Server is still denying access to it. I will have a look at dropbear's config now. Maybe empty (or root) login are not allowed... – SiLeX May 16 '13 at 19:54
  • The problem has been solved. I have made the password for root empty in /etc/shadow and created a normal "admin" user on the web interface. the sshd denys empty password logins and public-keys, so I logged in as the user "admin" and connected successfully to sshd on the nas. Then I could easily run "su" what made me the root user (root group). Now I change the password with passwd to a secure one and reconnected successfully. Thanks, Gabe! – SiLeX May 16 '13 at 20:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.