Does anyone know about logging in to SYSTEM(high privileges) user in windows 7?.

In my XP machine I do:

command prompt:

at 10:20 /interactive cmd.exe

then closing the explorer.exe and reopening that.

But it shows some warning in windows 7 and also not performing the scheduled task at the specified time:

Due to security enhancements, this task will run at the time expected but not interactively. Use schtasks.exe utility if interactive task is required ('schtasks /?' for details). Added a new job with job ID = 1

Is it possible in windows 7 ?

  • 1
    ... Why do you want to do this? If you think you need to run something as SYSTEM, then running something as SYSTEM is not your problem. Launch the command prompt as an administrator - If you're having permissions issues with an elevated command prompt, post about that problem specifically. Running as the SYSTEM user is not the answer. May 16, 2013 at 16:22
  • 2
    The answer to this is YOU DON'T - System is a service account and should not be logged into. Perhaps you should add a new question or edit this one to explain what you want to achieve and we'll try to point you in the right direction. May 16, 2013 at 21:04

6 Answers 6


Use PsExec from Microsoft with the -s and -i options.

To start a command prompt running in the local system account.

Add the file containing PsExec to your PATH environment variable.

Start an elevated command prompt by right-clicking cmd.exe and clicking 'Run as Administrator'

Enter the command: psexec -sid cmd.exe

See the example 42 minutes 20 seconds into http://channel9.msdn.com/Events/TechEd/NorthAmerica/2012/SIA311

If this isn't what you are trying to do, I have misunderstood your question.

  • But that didn't solve my problem... i'm not able to access the SYSTEM user with that...
    – Gowtham S
    May 16, 2013 at 18:34
  • @Gowtham can you explain what you are trying to accomplish, give us the big picture. You are falling in to the XY Problem and if you tell us what you are trying to do we may be able to tell you a way to accomplish it in a different way. May 16, 2013 at 21:05
  • My C drive is showing warning of low disk space, i'm using windows7 now, i have to delete ProgramData(its is a hidden folder) in my C: drive, its is nearly occupying 10GB of my C drive, if i try delete the content of the fold it showing Access is denied. I had the same problem in my XP machine before win7, i will delete those unwanted and system caches through the SYSTEM user, in that also Administrator have no privilages to delete the hidden files in ProgramData.
    – Gowtham S
    May 17, 2013 at 6:57
  • This is not a user account to log in and interact. It is a special account. It is used by the system to control system services. However, you can launch certain programs and services as system user. First answer resolves your problem. You are accessing programs with the system account. It is not a user account so simply you cannot login as System user because there is no such user.
    – Epoxy
    May 16, 2016 at 1:35
  • 1
    You should NOT delete the Program Data folder. It is a windows reserved. If you want to access the Program Data, do the following (you don't need system user to access this folder. Don't use system user to delete system folders). - Open the Folder Options panel using Windows Explorer - Click View tab and find Hidden files and folders. - Click 'Show hidden files and folders' and click OK. Now you should see program data folder. Why don't you do a disk cleanup instead?
    – Epoxy
    May 16, 2016 at 1:40

Yes it is but it is hard to explain. Well technically your logged into the system account when your not logged into your account. Change Sethc to any other name then copy cmd.exe and name the copy sethc then on login press shift 5 times. it opens CMD.EXE. then type in explorer.exe then you are in the system account!


For the Question:

I use anothor method: Search for a program entitled runassrv, put it in System32, and run:

runassrv add /name:"SystemCmdService" /cmdline:"cmd" /type:InteractiveProcess

This will add a service called "SystemCmdService". Start this service:

sc start SystemCmdService

A dialog will pop up (in the taskbar). Click "View message" and you will go to another screen with a cmd window running in System account and another dialog to come back.

Don't forget to delete this service later:

sc delete SystemCmdService

For the Problem:

I see you just want to delete some files in the comments above.

The actual problem may be the access control of the files. There ARE certain files that even System cannot open.

Please try:

  1. Login as Administrator, temporarily disable UAC;

  2. Right click the file, select Properties, Security tab, Advanced.

  3. First goto Owner tab, Edit, change the owner to you (Administrator), save.

  4. Close and reopen Security tab, Advanced, change the access control so that you have Full control.

  • I just saw runassrv is reported as Trojan/Win32.Zlob, possibly because it is often used by poorly-written trojans that want SYSTEM privileges too. I use it as a SYSTEM service without any problem. nssm (the Non-Sucking Service Manager) is an free and open source (public domain) alternative.
    – jingyu9575
    Sep 30, 2013 at 3:34

You want to login as System user to run command with the priviledges of this special user. You can't log in but it's possible to run programs with this user priviledges.

One solution [but only for 64 bit OS] is RunAsSystem


Replace Utilman.exe with cmd.exe:

  1. Navigate to the system folder and select cmd.exe
  2. Replace Utilman.exe with cmd.exe
  3. Press Ctrl-Alt-Del or logout and click on the help icon on the bottom left of your computer

You are in the system command prompt. You can start explorer.exe and do any administrator stuff with it.


Here is another method:

1) Use another operating system (or Windows installation CD - repair your computer - command prompt) to access the hard drive

2) Rename C:\Windows\System32\osk.exe to osk.exe.old

3) Rename C:\Windows\System32\cmd.exe to osk.exe

4) Reboot into Windows, then click on the Easy Access button in the bottom-left keyboard.

5) Check the "onscreen keyboard" box. You will see a command prompt.

6) Finally, type explorer into the box and press ENTER. You will see a taskbar below your login screen!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .