I just installed my new SSD, and I put Windows 8 on it. Previously I had a hard drive with both Windows and Linux partitions. After finishing the installation of Windows 8 on the SSD I formatted the Windows partition from the old disk (I did it from the SSD). Since then, the old hard drive no longer sees any OS when I boot on it. So far I had not changed the GRUB, everything was done automatically when I installed Linux. GRUB is in the Linux partition. I tried using EasyBCD to have a dual boot when I use the SSD. EasyBCD sees indeed the Linux partition, but even when I add it as an entry there is no change at startup.

So how can I have a dual boot when I start on the SSD? Thanks

  • have you tryied reinstalling grub? – AAlvz May 18 '13 at 20:56
  • No, I haven't. What is the easiest way to reinstall it on the old disk, since it won't boot? – iamdede May 18 '13 at 20:57

Have you mounted already all your HDD Partitions? You should try to reinstall grub like this:

sudo fdisk -l  #To view all your partitions

then mount your linux partition:

sudo mount /dev/sda5 /mnt  #pay attention to the number of your linux partition. 

and finally:

sudo grub-install --boot-directory=/mnt/boot /dev/sda

Then reboot and check if it worked. After repairing grub you could try sudo update-grub again..

hope it helps you!

  • Thanks, I did from a live cd and I'm now able to boot on Linux. Would it be possible to add Windows to the grub so it would be listed in the list of OSs at startup? I also have a huge problem : I cant connect to the internet anymore. I can connect to wireless networks but can't view any webpage or ping anything. I think it's linked to Windows 8 and not to grub. I will create a new topic but let me know what you think is the issue. Thanks. – iamdede May 19 '13 at 15:10
  • ok. For that windows issue you could check this question .. MAybe adding win7 is similar to add win8. But yes, you should open a new topic... And internet.. It is odd.. have you checked your Access Point alreadY? .. – AAlvz May 19 '13 at 22:41
  • You welcome!.. let me know what the internet problem was! – AAlvz May 21 '13 at 14:10
  • 1
    It was DNS issue. I fixed but the mystery is why it appears right after I reinstalled the Grub. It was working fine before. – iamdede May 21 '13 at 18:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.