I'm trying to assign color palette on my gnome-terminal but it doesn't change at all... any clue?


enter image description here

Aditional info:

  • Fedora 18 64bits (shiny new)
  • GNOME Terminal 3.6.1
  • $XTERM set to xterm-256color
  • I tried with new profiles, even with new accounts... same
  • Have you tried opening a new terminal after making changes? – demure May 21 '13 at 2:33
  • yes, . .bashrc and even rebooting the machine – meem May 21 '13 at 2:39
  • Minor correction, I think you mean $TERM set to xterm-256color. You shouldn't need to restart or reboot anything -- for me with the same setup the colours change straight away. – mavit May 21 '13 at 11:47

In fedora 19 I solved the problem by un-checking the "use colors from system theme" checkbox in the edit/profile preferences/colors pannel.

|improve this answer|||||

Fedora configures ls to use entries of the 256-color palette if your $TERM is set accordingly; see your $LS_COLORS variable and the /etc/DIR_COLORS* files. On gnome-terminal's UI you can only configure the first 16 of these.

That is, probably the blue and green colors your ls produces are simply not the "standard" blue/green colors, but one of the "extended" ones.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.