4

I have a new ISP and only have a Dual Stack - lite connection now. That means I can't access my router via IPv4 anymore, since the external IPv4 address is private. I have native IPv6 connectivity.

My IPSec tunnel cannot work on IPv4 only networks (the majority of them).

I have a root server with both IPv4/v6 connectivity. Can I use this server to forward IPSec packets? If so, how? I tried using socat but my iPhone just kept saying it can't reach the VPN endpoint. The commands I tried (parallel) was:

socat UDP4-LISTEN:500,fork,su=nobody UDP6:fqdn:500
socat UDP4-LISTEN:4500,fork,su=nobody UDP6:fqdn:4500
socat IP-RECVFROM:50,fork,su=nobody IP6-SENDTO:fqdn:50
  • You should be able to build a IPv6 tunnel this then transports your IPv4 packets to the server. (Of course the server must then do a IPv4 NAT for these packets) But I think socat can't do this, you would need something more powerfull for this – André Schild May 21 '13 at 16:04

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.