17

I'm trying to learn how to use Linux with a Debian 7 VM that has no GUI.

The 640x400 window I'm working in feels a little constricting and would like to make it bigger, say 1024x768.

How can I do this?


Hello, I no longer use this type of work flow. I was just getting my feet wet. I prefer ssh now :)

5
  • what virtual machine software?
    – nc4pk
    May 22, 2013 at 1:11
  • @tapped-out Hyper-V. There's only an option to go full-screen, and all this does is center the shell on a black screen. May 22, 2013 at 1:17
  • 1
    Bash has no resolution. It is the name of a shell. What you are asking is similar to asking how you change the resolution of Firefox. What you are probably looking for his how to change the resolution of the Linux console. For the record, my solution is to simply install an SSH server into the VM and then use an SSH client to connect, and minimize the VM console. You have far more control that way.
    – Zoredache
    May 22, 2013 at 1:46
  • @Zoredache Thanks, I understand now. I tried your solution as well and it works. I guess my only problem with it is that it loses the system colors and some formatting (i.stack.imgur.com/QXwUR.png), but I think it's worth an upvote if you made it an answer. May 22, 2013 at 2:02
  • setting something like "video=1024x768" in GRUB_CMDLINE_LINUX_DEFAULT may help. this helped me. i found this from lists.debian.org/debian-user/2017/12/msg00961.html , which i found googling "debian 10 framebuffer resolution". Jun 6, 2021 at 17:02

2 Answers 2

25

What you basically want to do is change the resolution of the framebuffer. Here's the process I used (supposing that your desired resolution is 1024x768, and that Hyper-V's framebuffer supports this resolution):

  1. Open up /etc/default/grub with superuser privileges: sudo nano /etc/default/grub
  2. Uncomment/add the following lines:

    GRUB_GFXMODE=1024x768x32
    GRUB_GFXPAYLOAD_LINUX=keep

  3. Save the file and exit: Ctrl-O, Enter, Ctrl-X
  4. Run update-grub as superuser: sudo update-grub
  5. Reboot, and (hopefully) enjoy a higher-resolution console!
3
  • does not work for me with debian 10. i tried 640x480, then 320x240, neither work. i use qemu, and window is too big, if i "zoom out", font is to small. Jun 6, 2021 at 9:30
  • i had grub-legacy installed by mistake. after i fixed it, using "keep" makes grub hang, using "320x240" in GRUB_GFXMODE and GRUB_GFXPAYLOAD_LINUX, or in GRUB_GFXMODE, does not make it used in linux stage, only somewhere near grub stage. Jun 6, 2021 at 16:51
  • with virtualbox this works if the (virtualbox -> setting -> display -> ) "Graphics Controller" is set to "VMSVGA" only. tested using debian 10.10. see also superuser.com/a/1403131/402021 lost a lot of time and found only by accident :face_palm:
    – bugrasan
    Jul 10, 2021 at 15:00
0

In addition to nc4pk's answer.

The file /etc/default/grub on my openSUSE 42.1 contains the comment:

If you change this file, run ´grub2-mkconfig -o /boot/grub2/grub.cfg´ afterwards to update /boot/grub2/grub.cfg.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.