This question already has an answer here:

Something I find extremely annoying with Google Chrome is the fact that it will autocomplete my searches in the Omnibox, adding or extending words.

For example, if I type "youtube down" it automatically gets extended to "youtube downloader", which is a totally different query.

Is there anyway to disable this feature? It would be preferable to keep the suggestions, but just have them not automatically selected when typing.

marked as duplicate by Tanner Faulkner, James Mertz, Karan, Tog, Breakthrough May 23 '13 at 14:15

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


Turning off Predictions in the address bar:

  • Clear browsing history (optional - only do this if you don't want to see matches from your browsing history).

  • Wrench icon --> Options --> Under the hood --> Privacy --> uncheck "Use a prediction service to help complete searches and URLs typed in the address bar"

link to google Chrome documentation

  • This still doesn't turn off suggestions from your history and bookmarks. It only prevents Chrome from fetching suggestions at Google's servers. – Pieter Jun 23 '14 at 18:31

Install Fauxbar for Chrome and be happy with it. It will add an alternative address bar to Omnibox. By entering "youtube down" in Fauxbar and pressing Enter will directly take you to downrightnow.com.

Either that or replace Chrome by Firefox.

I personally don't find this very annoying, all I have to do in a situation like that is type in "youtube down" and press Backspace once, and then Enter. This takes you to the Google search result page, and you have to click the first link to get to the above mentioned website. The address bar in Firefox works the same way.

Not the answer you're looking for? Browse other questions tagged or ask your own question.