13

enter image description here

My vim only show 16 lines, using terminator, how can i make it back to full screen? It is very annoying. Don't know what settings has to change.

  • 2
    Outside of Vim, what is the output of $ echo $LINES and $ echo $TERM? – romainl May 23 '13 at 6:49
9
  • You may try resizing your terminal to force vim to recalculate its size;
  • You may try quitting your vim session, typing reset and restarting vim;
  • Inside vim you may try something like: :set lines=34
| improve this answer | |
3

I had the same issue in a docker container, I did that:

export set LINES=58

| improve this answer | |
  • 3
    What does this setting actually do? – music2myear Feb 16 '17 at 19:20
  • 1
    This will set fixed number of lines. But auto size is needed. – AstraSerg Jun 14 '18 at 11:17
  • 1
    FYI, the current workaround for this issue in Docker seems to be to resize your window. For some reason, it's not getting the dimensions initially but a change to the window will get passed on. – KC Baltz Jun 27 '18 at 22:00
3

Use the following commands to enable the full screen:

export TERM=xterm
stty rows 36 cols 150
| improve this answer | |
1

reopen your vim session after entering "resize" command in your linux terminal. It worked for me.

| improve this answer | |
  • 2
    can you share some examples of the 'resize' commands used? – p._phidot_ Jun 17 '19 at 7:50
0

In response to "can you share some examples of the 'resize' commands used?", this is what I found.

Using bash on Ubuntu (16.04.1), the "resize" command reports the current terminal window size and seems to show commands to resize the window.

$ resize 
COLUMNS=80;  
LINES=24;  
export COLUMNS LINES;  

I entered that text as a command, and that did not seem to affect the terminal window size nor vi window size. In my Ubuntu terminal window, vi automatically uses the full of the current terminal window, anyway.

On an embedded linux platform (Technologic TS-4900, Yocto Linux), bash shell, "resize" was not recognized. However, the following shell command changed the vi window size for me.

$ stty rows 40 cols 100

Others have instructed to use "export TERM=xterm" first, but that was not necessary for me.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.