I've been having a lot of trouble with freezing and bsods with my computer lately, so I took the chance to do a full upgrade.

My new system only shares the VGA with the old one, nothing more. Current specs are:

  • MOBO Gigabyte 970a-d3 AM3+
  • 2x4GB Patriot PSD34G160081
  • NVidia geforce 560 TI
  • ADATA SSD 256GB
  • 2 old HDDs for data storage
  • Windows 8 x64

In my bad luck, even with my new system I kept having freezing and bsods. I started running some tests. First thing was memtest, which was keeping failing on test #5 on every single ram module, on different slots.

I had both the ram replaced with other two of the same model, only to have memtest fail again in the exact same way.

I started fiddling a bit with DRAM voltage (not much, just upping by 0.05 at a time a couple of times) and lowering the frequency from 1600 to 1333 with no results.

Also, Prime95 fails on all tests (small FFT, large FFT, blend), with blend almost always ending in a bsod with CLOCK_WATCHDOG_TIMEOUT error. The errors reported in Prime95 before it BSODs are rounding errors and sum errors, in all tests.

I then tried the old ram from the old computer. 4x2GB, cannot remember the manufacturer but I'm pretty sure they were Corsair. 0 errors on memtest after 14 hours, but Prime95 fails in the exact same way.

Apart from the tests, the system is unstable, freezing and BSODing randomly, sometimes after a couple of minutes of uptime, sometimes after even one day or more. I got many different BSODs errors, I can get the list and update the post if the could help with the analysis, but the only consistent one is the CLOCK_WATCHDOG_TIMEOUT.

I also tried to rule out the VGA on both the old system and the new system by switching it with another one (an old ATI I had) and I kept having crashes on both systems.

I usually have no problems troubleshooting my hardware but this time I think it's beyond my skills.

Any help will be immensely appreciated.

EDIT

There's no overcloking, no custom bios settings apart for my slight fiddling with DRAM voltage.

EDIT 2

I updated my MOBO bios. As of now, small fft always passes, while large fft and blend fail almost instantly. I haven't had any BSOD since the bios update, but I'm having freezes. Memtest still shows error in test #5.

Still confused. Mobo maybe? Or cpu?

  • Did you try overclocking your PC? As this normally happens if you overclocked too far. – Kevdog777 May 23 '13 at 7:43
  • I forgot to mention it's all on factory settings, apart for my experiments on voltage. Adding it now. – Matteo Mosca May 23 '13 at 7:46
  • So, when you upgraded, you also replaced the mainboard? Also, what CPU are you using? Did you upgrade that as well? – Der Hochstapler May 23 '13 at 9:17
  • Yes, the MOBO is the one stated in the post, it's a new one. Also a new CPU, an AMD K10 eight core. Can't remember the exact model now, have to check the box once I get home. – Matteo Mosca May 23 '13 at 10:23
  • If your memory passes Memtest86+ but fails Prime95, this is almost certainly an issue with the CPU. While I wouldn't rule out the motherboard, the first thing I would replace is what Prime95 tests - and that is the CPU. – Breakthrough May 26 '13 at 18:55

If you've put known good RAM in a PC, but Prime95 still fails, your CPU is bad. To absolutely confirm, remove all the hardware you can from the system and disable everything you can from the BIOS.

Either your CPU is physically bad or not cooled properly.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.