1

I'm trying to install MS SQL Server 2012 Express on a virtual machine at a client. It's fresh install of Windows Server 2008 R2 Enterprise SP1. I added the "File Services" and "Application Server" roles, and installed the .NET framework 3.5.1 feature.

I downloaded the SQL Server setup files in a single EXE from Microsoft. (Took the Advanced Tools bundle). After the setup unpacks, I see a Command window flash, then nothing happens.

I then unpacked the EXE file by hand and started setup.exe, which crashes with the following error:

ERROR: Runtime error: Could not load file or assembly 'System.Data, Version=2.0.
0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencie
s. The module was expected to contain an assembly manifest.

I have done the same installation on different VMs probably a hundred times and never got this error. Can anyone help, please?

  • 1
    Your installation of the .NET Framework is corrupt based on the error message you recieved. Try installing .NET Framework 4.0 and repair the installation of the curent .NET Framework installation. – Ramhound May 23 '13 at 12:27
  • 1
    per this thread, repairing your .net framework install may help. usually I would expect "System.Data, Version=2.0.0.0" to refer to the .net 2 framework runtime. stackoverflow.com/questions/4403363/could-not-load-system-data – Frank Thomas May 23 '13 at 12:56
  • Thanks, but that didn't help. I repaired the .NET 4.0 installation and also ran Windows Update to get the latest .NET 4.0 updates. But still I get the same error. – alexraasch May 23 '13 at 12:57
  • I just ran sfc /scannow and it ran into some errors concerning .NET 2.0 files, e.g. 2013-05-23 15:30:08, Info CSI 00000025 Hashes for file member \??\C:\Windows\Microsoft.NET\Framework64\v2.0.50727\CustomMarshalers.dll do not match actual file [l:40{20}]"CustomMarshalers.dll" : sfc also reported that it couldn't correct the files because the source files are also corrupt. Do I need to reinstall the whole system? – alexraasch May 23 '13 at 13:47
1

Error on the need. Net 2.0. There is a wizard, preparing the environment for the installation, use SQL Server 2012 CD with the evaluation version.

Microsoft® SQL Server® 2012 Evaluation

System Configuration Checker SQL Server 2012

System Configuration Checker SQL Server 2012 setup

see .Net Framework:

%SystemRoot%\MICROSOFT.NET\FRAMEWORK\V2.0.50727\aspnet_regiis.exe -lv

var 2, 32-bit:

dir /A:D /B %SystemRoot%\MICROSOFT.NET\Framework

var 2, 64-bit:

dir /A:D /B %SystemRoot%\MICROSOFT.NET\Framework64

Run to Fix:

cd "%ProgramFiles(x86)%\Microsoft Visual Studio 8\SDK\v2.0\Bin"
gacutil -I "%windir%\Microsoft.NET\Framework\v2.0.50727\System.Transactions.dll"
  • Sorry, I don't understand what you want me to do. If I run that last command I get: 1036 3082 v2.0.50727 v3.0 v3.5 v4.0.30319 – alexraasch May 23 '13 at 13:03
  • del .Net 3.5 and install microsoft.com/en-us/download/details.aspx?id=25150 – STTR May 23 '13 at 13:23
  • Thanks for the screenshots. However, the Setup never even displays. When I start it on the command line, I get the error I posted above and nothing happens. – alexraasch May 23 '13 at 14:06
  • 1
    @alexraasch maybe command help? SQLEXPR_x64_ENU.exe /ACTION=Install /FEATURES=SQLEngine /INSTANCENAME=MSSQLSERVER /SECURITYMODE=SQL /SAPWD=******** /SQLSVCACCOUNT="NT AUTHORITY\SYSTEM" /SQLSYSADMINACCOUNTS="BUILTIN\ADMINISTRATORS" /TCPENABLED=1 /NPENABLED=1 /HIDECONSOLE /SKIPRULES=RebootRequiredCheck /IACCEPTSQLSERVERLICENSETERMS /Q And you reinstall .Net 3.5? – STTR May 23 '13 at 14:22
  • Thanks, but that didn't work either. See my next answer. – alexraasch May 24 '13 at 8:19
0

OK, so it seems the problem is totally unrelated to the .NET framework. One of the sys admins just told me that the storage system, on which the VM is running, seems to be corrupt. So it's either a hardware failure or an incompatibility between the storage system and the VM tools, especially vMotion. Looks like we will have to setup the VM again from scratch. Thank you all for your help!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.