0

I was working in a copy of my directory in another server. When I moved it to the one with SVN, where I am supposed to work, it overwrote the original directory. The files that were supposed to have .svn no longer had it. I can't add the files, as it says they are not under version control. I cannot commit anything, I keep getting a "(405 Method Not Allowed) in response to MKCOL ".

I tried to fix it by doing svn add --force, but that didn't work. I tried making a copy of the directory and then doing svn mv COPYNAME/ ORIGINALNAME/ and when I tried to commit I got the same error message.

How can I clear out the old svn data on this directory and replace it with the new data?

migrated from stackoverflow.com May 23 '13 at 21:57

This question came from our site for professional and enthusiast programmers.

  • Possible duplicate of stackoverflow.com/questions/96313/… – AlG May 23 '13 at 16:52
  • 1
    That probably means it's trying to make requests to the special !svn urls in the wrong place. Check that svn info looks correct. – Rup May 23 '13 at 17:03
4

Do a new checkout. It's your only choice. Then, you can copy files changed from your old working directory to your new one.

  • 1
    Thanks. The problem was twofold. I had to checkout, and the server was actually down for a while. – Nicholas May 23 '13 at 19:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy