I'm the owner of a Microsoft touch mouse and like it a lot. However it seems that it stops working when I startup Visual Studio 2012 under admin privileges. I read somewhere that I also need to start ipoint.exe under admin rights but that doesn't seem to do the trick.

Anyone else has an idea?

  • I would just suggest try getting rid of ipoint.exe its just a waste processing power. – Ramhound May 24 '13 at 11:34
  • @Ramhound and what would be an alternative be for the gestures of my touch mouse in that case? – Kris van der Mast May 26 '13 at 6:19
  • At the very least you can confirm if that process is the reason its not working. If it then does work you can report the problem to Microsoft. If you report it before Update 3 is release it might be fixed. – Ramhound May 26 '13 at 15:45
  • I switched to the Logitech T650 touchpad :-). – Kris van der Mast May 28 '14 at 7:51
  • Alas this problem still exists in VS2015 (any elevated program) and Windows8/8.1 and Windows 10... Windows 7 always worked with this. The Logitech Touch Mouse T620 scroll works under Admin privileges in WIndows 10 however, and is quite similar. Interesting that Microsoft can't work this out. I've switched just to get scrolling back in Visual Studio. – PandaWood Feb 24 '16 at 23:30

You can use Per Salmi's method or if you want to just modify the ipoint.exe file you can do that as well:

  1. Open file explorer to Microsoft Mouse and Keyboard Center folder (default: C:\Program Files\Microsoft Mouse and Keyboard Center)
  2. Right click ipoint.exe and choose Properties
  3. Choose Compatibility tab
  4. Check Run this program as an administrator

Reboot (or kill the ipoint.exe process and restart it) and it should now work in programs running as admin.

One caveat with this method: You'll need to run the MouseKeyboardCenter.exe as admin as well or it will hang. Do the same steps above on this file in the same directory.

I have solved this problem with the touch gestures in admin applications by creating a Task Scheduler activity.

First I removed the ordinary startup of IPoint.exe as it doesn't work for applications running as admin.

Use the Windows Task Scheduler and create a new activity with the following properties:

  • Start at user login
  • Action set to start application c:\Program Files\Microsoft Mouse and Keyboard Center\ipoint.exe
  • Run with highest privilege

This will make the mouse touch gestures work in all applications running as a normal user and in admin privilege applications.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.