6

Info: this question has been revived from ashes after several years, during which some hw/sw features changed, but still on very the same computer.

I recently upgraded to Windows 8. Now it is 10.

I found that a strange phenomenon is happening often during day or night hours (night hours being the most annoying).

I usually turn my computer "off" by putting it into standby mode so I can resume work fast when I need it. Tonight, it happened again: at 5:08 local time, without me or anyone else touching keyboard or mouse, the computer woke up from standby, waking me up too.

I got up and returned it to sleep by pressing the power button as usual. After less than 20 seconds, the computer woke up again, so I had to log in and shut down the system.

Motherboard is an ASUS Sabertooth 990FX. BIOS doesn't show any "wake up on RTC alarm" option. I don't think it could be a WOL signal (wakeup on LAN) both because my home network is under NAT without DMZ to my computer, and also because I don't think any other device in my home might send a WOL packet to my desktop. Anyway, BIOS shows no option about that.

About a week ago it happened in the middle of the day, thrice. I put the computer to sleep and less than 20 seconds later it came back to life.

Is it a hardware or software failure? How may I fix that?

Additional information about hardware. Here are the most relevant USB devices connected to the computer:

  • Keyboard & trackball
  • Smartcard reader
  • Xbox 360 controller receiver (with controller turned off)
  • Webcam
  • 3D Vision emitter
  • Bluetooth pen
  • Android phone under charge
  • USB headset
  • Micro-SD reader

As suggested by @JoseManuelGomezAlvarez I did

C:\WINDOWS\system32>powercfg /waketimers
Il timer impostato da [SERVICE] \Device\HarddiskVolume3\Windows\System32\svchost.exe (SystemEventsBroker) scade alle 4:08:21 AM il 8/1/2017.
  Motivo: Verranno eseguire 'NT TASK\Microsoft\Windows\Media Center\mcupdate_scheduled' attività pianificate che richiedono la riattivazione del computer.

Translated: Looks like Windows Media Center wants to wake the computer up to make some collection update perhaps.

A quick search on Google (worth an answer soon) brought me on a page with a clever title: Windows 7: mcupdate_scheduled wakes computer at night

So I found the potential culprit task, unchecked the option to wake the computer up and............ I'll give you an update by tomorrow enter image description here

8
  • 1
    You might want to pull the network cable (or disable your Wifi connection) to distinguish if the signal comes from the outside or from the computer itself.
    – Jan Doggen
    May 24 '13 at 12:04
  • Fortunately, computer has no wifi (and even if it had I believe it should be shutted off on standby as happens with laptops). I'll try that May 24 '13 at 12:48
  • What is the make/model of the keyboard, mouse, and pen? Also, have you tried unplugging the controller receiver?
    – Kruug
    May 24 '13 at 13:52
  • Kyeborad and trackball are Microsoft products. A Natural Keyboard Internet (as I may remember) and a Optical Trackball. The Bluetooth is a Broadcom 2045 EDR. The issue occurred with and without the Xbox receiver (I have attached it very recently, the problem didn't happen only this night) May 24 '13 at 14:13
  • If you search here you will find that this is a fairly common problem. First thing to do is to make sure nothing is causing your mouse to move -- even a small vibration may be enough. Then you need to track down other causes for waking, and, among other things, many apps add Task Scheduler items that go off at random times and wake the box. May 24 '13 at 14:25
1

As suggested by David, powercfg /waketimers showed the following output

C:\WINDOWS\system32>powercfg /waketimers El temporizador establecido por [SERVICE] \Device\HarddiskVolume4\Windows\System 32\svchost.exe (SystemEventsBroker) expira a las 23:35:31 el 08/01/2017. Motivo: Windows ejecutará la tarea programada 'NT TASK\Microsoft\Windows\Windo wsUpdate\AUScheduledInstall' que solicitó la reactivación del equipo.

And a Google search pointed to this Microsoft answer:

https://answers.microsoft.com/en-us/windows/forum/windows8_1-performance/auscheduledinstall-disabled-but-re-eneables-itself/4332d01e-62cd-4b1e-8b21-a12e181e413d

Basically two solutions are provided:

Method 1:

Follow the steps to detect and disable the device using Command Prompt (admin):

Press Windows+X keys and select Run as administrator.

Type the following command and hit Enter:

Powercfg -devicequery wake_armed

You will get the name/names of the devices. To disable a specific device from waking the computer, run the following command:

Powercfg -devicedisablewake "devicename"

Note: Make sure that you replace the “devicename”placeholder with the name of the device that you want to disable. If this issue still occurs after you disable one device, disable the devices in this list one by one until you determine which device is causing the issue. If you want to re-enable a device to wake the computer, run the following command:

Powercfg -deviceenablewake "devicename" command.

If the issue still persists, proceed further to the next method.

Method 2:

Let's disable the option in Group Policy to avoid wake up patters of the computer through scheduled tasks:

Press Windows+R keys and select "gpedit.msc".

Navigate to Computer Configuration -> Administrative Templates -> Windows Components -> Windows Update.

Modify the "Enabling Windows Update Power Management to automatically wake up the system to install scheduled updates" policy.

Select Disabled from the list of options in this interface.

If you are unable to use the Group Policy Editor method or it's not available in the current version of Windows, use may use the Registry Editor method: Disclaimer: Please make sure that you backup the registry before proceeding with the steps mentioned below:

Press Windows+R keys and type "regedit". Hit Enter.

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU (you may need to create the WindowsUpdate and AU keys) and create a DWORD value named AUPowerManagement. Set this value to 0.

Or create and import the following file AUPowerManagementDisable.reg

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU]
"AUPowerManagement"=dword:00000000
7

I had a similar problem - but the PC resumed just after 10 seconds!

I checked the Wake On Lan thing, control-panel settings, device settings and what else I found, but nothing worked.

So I got curious, what caused the wake - and found the pretty handy Microsoft commandline tool powercfg.exe (comes with Windows).

Wait for the computer to resume unexpectedly and start

cmd

with administrator rights. Type

powercfg /lastwake

and it displays the hardware responsible for the wake.

In my case it didn't show any device responsible. But there's is another command

powercfg /waketimers

It shows all processes which registered resume-timers. In my case the Samsung hard disk tool "Magician" was responsible for it - uninstalled it and now everything is working as expected again!

I hope this helps you!

2

Type Mouse into the start menu search box, or the Control Panel search box, and then open up the Mouse Properties panel. Find the Hardware tab, select your mouse in the list, and then click the Properties button.

Mouse Properties

You’ll have to click the Change settings button before you can see the Power Management tab…

Change Settings

And now, you can uncheck the box from Allow this device to wake the computer.

Uncheck the Box

That’s all there is to it.

Source. Written for Windows 7, should work in Windows 8.

3
  • +1. let's see tonight May 28 '13 at 19:13
  • I won't withdraw my upvote, but that DIDN'T work. At 5:08AM the computer woke up again. I immediately turned it off May 29 '13 at 11:49
  • try the first answer @usr-local
    – user648246
    Jan 7 '17 at 3:01
1

You might need to check the tasks in the task scheduler. Tasks can be allowed to wakeup the computer. To check if that is the case, please see tab condition, checkbox "Wake the computer to run this task" on each scheduled task.

3
  • This is interesting. I have found a few task (but one was scheduled for 5PM, not 5AM) that had that checkbox activated. However, Windows 8 features looooooooooooooots of tasks in its tree. Some .NET Framework related tasks (like NGEN 4.0 Critical) are marked with that option too. I'll carefully take a look but meanwhile I'd ask if there is a way to globally uncheck that option or to get a list of tasks allowed to resume by deep searching in the tasks tree May 24 '13 at 14:11
  • Another option found: in Power Management's Advanced Options I found "allow resume timer" (sorry but my Windows is localized) that is marked DISABLED. This should mean that tasks are never allowed to resume from standby. May 24 '13 at 14:15
  • @djechelon: If this option is disabled, then I'ld guess the wakeup reason cannot be a scheduled task. May 24 '13 at 14:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.