I've got this wireless connection issue that I want to ask about.

A couple of days ago, I set up a static IP address so that I can use DCC IRC send option.

However since I'm in uni I always carry my laptop around and connect to various secured/unsecured networks that refuse connection because I've set up a duplicate IP address or some other similar problems.

The problem is the IP is bound to the network adapter and not the wireless profile, so if you change wireless profiles you need to change it back to automatic, to connect to the library/uni/coffee shop's WiFi.

Is there a way to set up 2 wireless network connections so I can choose (or that it does that automatically) which one to use, so that I can at use a static one in my flat and the automatic one away?

Extra stuff: I'm using Asus K73S with Windows 7 and Atheros AR9002WB-1NG wireless adapter I've found someone asking something similar being asked before: Static IP and DHCP on the same network adapter in Windows 7 but that's at the same time whereas I was thinking more in the lines of: one static for the house and one automatic for other places.

  • The easier way would be to Change to dynamic IP always and Change your router to always give you the same IP address. – Werner Henze May 24 '13 at 13:52
  • I suppose you set up the static address for the purpose of adding port forwarding rules on your home Wi-Fi router? Then look at the DHCP-related configuration on your router — maybe it supports adding DHCP reservations (static allocations). If it does, you need to add such allocation for the Wi-Fi MAC address of your machine, and use DHCP for Wi-Fi everywhere — after doing this, you will always get the configured IP from the DHCP server on your router, and your port forwarding rules will work. – Sergey Vlasov May 24 '13 at 14:01

You could change the IP network settings so that the default config (tab page Default) is using DHCP and the alternative config (tab page "Alternative configuration") is with a fixed IP address. So if Windows does not find a DHCP Server, the alternative config is used. The problem is, that Windows tries for about 2 minutes. In these two minutes you will not be able to connect to the internet if DHCP is not available.

I'ld try to go the easier way and change to dynamic IP everywhere. Try to configure your router to always give your computer the same IP address.

If both options are not a solution for you, you can write two short batch files utilizing netsh to quickly configure the ipv4 Interface and call the appropriate batch file depending on the network you are connecting/connected to.

  • You seem to be right on target as well as Sergey Vlasov in his comment to my question. – ljetibo May 24 '13 at 17:27
  • ...did not know shift+enter is newline here.... I'm going to go with the easier way you and @SergeyVlasov mention, a quick question though since I'm not that proficient in this matter, is there a more detailed tut available for this? I found something here link but it's a bit stingy. – ljetibo May 24 '13 at 17:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.