I'm configuring a "Windows Embedded Standard 7" install image, for an embedded application. Because of storage limits, "Internet Explorer 8 Browser" is not installed in the image, but "Internet Explorer 8 Engine and Display" and "Internet Explorer 8 Foundation" are.

After a fresh installation of the image, everything is working perfect. I can run inetcpl.cpl and the "Internet Properties" window opens. If I run services.msc the "Services" window opens on the "Extended" tab, and I can see all the services with an description to the left.

However, after installing "Security Update for Internet Explorer 8 for Windows Embedded Standard 7 (KB2847204)", I can suddenly not open the "Internet Properties" window anymore, if I run inetcpl.cpl nothing happens. When I open the "Services" window, the "Extended" tab is completely empty and if I click on the "Standard" tab the following error message is shown:

Unable to download.

Unable to open this Internet site. The requested site is either unavailable or cannot be found.

Please try again later

I can then uninstall KB2847204 and everything works perfect, like before.

So far I have tried to run the sfc /scannow command but that did not work.

As I'm not normally working on the Windows platform, I need advice on how to debug this problem..

Thanks in advance.


Had the exact same problem with a server running Windows Server 2008 R2 Enterprise (SP1). The description for MS13-038 (http://support.microsoft.com/kb/2847204) stated that the latest IE cumulative security update (MS13-037/KB2829530) should be applied as well. It wasn't on my system and after applying the cumulative update, the "services.msc" functionality was fully restored.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.