2

I can access, read and download from host via FTP, but can't upload files.

I tied to use Transmit (on Mac) and Filezilla also, but no success.

Then tried same on a different host and got the same problem.

Could not upload "logo.png".
Server said:
Error - 132: could not send file to remote host

could not send dialog error

I tried also PASSIVE mode on FTP client, and vice-versa, but again nothing.

The issue is only on the Mac-based FTP client as I am still able to connect using CuteFTP or Filezilla or other FTP clients on Windows.

  • I know this is probably the first thing you checked.. but your username/password for the FTP Server have Write Access? Oh, and have enough space left for you to upload more files? – Darius May 25 '13 at 15:37
  • Yes I checked this all, but everything is ok. It's working in windows CuteFTP or Filezilla or other FTP clients. I got problem only on Mac based FTP clients. – zur4ik May 26 '13 at 6:49
1

It sounds like the account you’re using doesn’t have Write access to the server, you need to confirm that with the server admin.

  • 1
    Account has write access because, when I use it with Windows based FTP clients, it's working properly. I get error on Mac based FTP clients. – zur4ik May 26 '13 at 6:51
1

After long time searching of solution finally found a solution.

Problem is caused by macs MTU settings:

Settings>Network>Advanced>Hardware

Put: MTU:1400

Finally FTP transfer is working properly.

-1

Uploading is not supported by macOS (or OSX) for quite some time through Finder, according to this post. Since the command line utilities for ftp is removed altogether, Finder may not be able to call those. However, try Filezilla or Cyberduck, both of which are Free Software (free as in freedom, though also free as in free beer).

  • That only affects FTP storage mounted in the Finder. It doesn't apply to standalone FTP clients, like Transmit and Filezilla (which the OP mentioned using). – duskwuff May 2 '18 at 22:01
  • @duskwuff As I said, it is possible with 3rd parties, but not possible through Finder via Command+K. I see no reason to downvote. – hyiltiz May 3 '18 at 21:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.