Alright, I've been struggling with this for the past few days. I'm trying to set up a personal ssh server on Lubuntu 13.04, but I've been having a few problems.

So far i've accomplished this:

  • I can connect locally, through my internal IP address,
  • I can ping myself through my external IP address through an external internet source
    (Mobile phone hotspot + Different computer)
  • I have a free dynDNS running, so that I don't have to type my external IP address.
    It works (if i connect to that IP locally, it forwards to my router)
  • I set up port forwarding in my router, temporarily disabled my personal and the router's firewall too.

The problem I have is that I cannot connect through ssh from a different computer outside my network: The usual response that I get is "Error.. [etc] No route to Host".

I tried using the 'canyouseeme.org' service, and the response is the same.

I use an Internet Service Provider called iiNet, and apparently they have some per-account port blocking features, which I have also disabled from their site.

I am running short on resources. DMZ does not work either, default port (22) does not work, custom port does not work either (9222, 9512 or 12222).

So I'm guessing it's either a router fault, or a fault on the ISP's customer-level firewall.

What other suggestions do you have?

Here's a post of my 'sudo netstat -plnt' to show that my sshd is listening on my custom ports.

Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name tcp 0 0* LISTEN 2151/sshd
tcp 0 0* LISTEN 1474/dnsmasq
tcp 0 0* LISTEN 886/cupsd
tcp6 0 0 :::12222 :::* LISTEN 2151/sshd
tcp6 0 0 ::1:631 :::* LISTEN 886/cupsd

I'm connected using a Edimax 7811-nu adapter (Default driver doesn't work, had to install a fixed one)

LE: If it's of any help, I'm using a BoBlite Router and the firmware version is BoBLite1500.


1 Answer 1

  • The fact that you can connect locally shows that the SSH server is running and working, so that is good.
  • The fact that you can ping yourself doesn't really tell us anything.
  • If you ping the DynDNS, does it ping your external IP? Have you tried connecting both to the external IP and the DynDNS?
  • If port forwarding is set up but you're still not getting any SSH access on that specific port, something is wrong with your configuration or your router.

From your netstat, it looks like your SSH port is 12222, and connecting to localhost:12222 on that machine works, so what's left is some connection failure from your external node (mobile hotspot) to your IP. Say that your dyndns is foo.bar, what happens if you run nmap to portscan foo.bar from your mobile hotspot? It seems to me your SSH port should show up there.

The fact that you get No route to Host also makes me suspicious of the router configuration. Can you supply some screenshots or copypastes of exactly what your router configuration states? What port to what internal IP, verify that internal IP matches etc.

  • When I use nmap on my DNS server (off another network), I get the following result. > Host is up (0.58s latency). > PORT STATE SERVICE > 12222/tcp filtered unknown > Host is up (0.58s latency). > PORT STATE SERVICE > 12222/tcp filtered unknown
    – dcb
    May 28, 2013 at 5:11
  • I just did a re-check on the ports and IPs, fired up my Hotspot, and voila.. It works.. Thanks for your help and support.. PS. The response from 'canyouseeme.org' is now good, therefore something must have changed, I don't know what, but I'm not going to question it.
    – dcb
    May 28, 2013 at 5:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .