I'm using google-chrome on Windows and Linux. On Windows, it is google-chrome 28 something (I use beta) and on Linux it is google-chrome-unstable Version 29.0.1516.3 dev.

After a recent update on Windows, I discovered that UI of location bar search and corresponding Google search page have been changed. When I use location bar to search things, it 'searches as I type'. and on search page there is no text-input box for search queries; instead the location bar is used.

I think it is very pleasant design and am looking forward to using this with my Linux (Fedora 18). Problem is that even after update to 29.0 google-chrome on my Linux is still using the old UI.

I went to chrome://flags to sort things out myself and reached a dead end. I changed following flags from default to enabled:

Enable Instant Extended API Mac, Windows, Linux, Chrome OS
Enables the Instant Extended API which provides a deeper integration with your default search provider, including a renovated New Tab Page, extracting search query terms in the omnibox, a spruced-up omnibox dropdown and Instant previews of search results as you type in the omnibox. #enable-instant-extended-api

Enable local first-load NTP in Instant Extended. Mac, Windows, Linux, Chrome OS
Whether or not the first New Tab Page load of a new window will automatically fall back to the local page when Instant Extended is enabled. #enable-local-first-load-ntp

Enable local-only Instant Extended API Mac, Windows, Linux, Chrome OS
Enables the Instant Extended API using only local resources, including a renovated New Tab Page and a spruced-up omnibox dropdown, but without search query terms extraction or Instant search results. #enable-local-only-instant-extended-api

After that, I have two search suggestions displayed as I type on the location bar. One is old search suggestion and there is new search suggestion displayed under it. The Chrome search page from location bar is not using the new UI.

The search option Display Instant results (Instant Extended is local-only).

is disabled. (greyed-out, can't toggle it myself).

What should I do?

Edit : I just enabled Enable Instant Extended API Flag only from above (changed the rest to default) and the UI experience is quite similar to that of windows. But I want to get rid of this double search suggestion. (See picture). Somehow I can toggle Display Instant Results option, but the double suggestion is still there.enter image description here

  • Have you found a solution for this? I have Chrome 30 and still the old tab page on Ubuntu.
    – brpaz
    Nov 12, 2013 at 20:11

1 Answer 1


I just updated to Chrome 33 today, and the renovated new tab page seems to be forced. I can't disable it in chrome://flags, as there is no option called Enable Instant Extended API.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.