3

I've recently installed Windows 8 on one of three drives (C:), and it's unable to search or index any of the other hdds (A: and B:) where I've stored any user files: music, videos, pictures, etc).

To test, under indexing options, I've set it to ONLY index my other hard drives, and it says "190 items indexed" and "indexing complete", i.e. only the information from the start menu, admin tools, etc on C:, and not any files on A: or B:. There should be roughly 51000 files and 9000 folders indexed in this test.

Search results always come up on any C: folders I've indexed, but not A: or B:. (Edit: it's able to search any cds, dvds, and the sd card on my phone, so is it an issue with my hdds, not windows search?)

On the start screen, if I edit my profile picture and hit "browse", it opens up a metro-style file explorer that effectively lists and previews every picture across my system, despite not being indexed. I can walk through my every folder this way, and view pictures that aren't even in the "picture library."

The apps on windows 8 can't find any files on A: or B: either. Music, video, and photos all claim that their respective libraries are empty, even though under the desktop file explorer, each library lists all files/folders I've associated with it. But if I move anything to C: and include it in a library, the apps and search will find it, though this isn't really a solution (Windows is on a 500GB hdd, whereas everything else is between 2 1TB hdds).

Any idea how I can search and index the other hdds? And possibly access them via apps?

1
  • Does indexing etc. work if you change the drive letters to D: and E: respectively (basically anything other than A: and B:)?
    – Karan
    May 28, 2013 at 0:23

3 Answers 3

4

I've seen other people have this issue. It's probably a throwback to the old days where your A: and B: were floppy disk drives. Windows probably still assumes that the A: and B: drives are floppy disks and so doesn't index or search them. If you change the drive letter the D: or above then it should work fine.

2
  • 1
    changing the drive names worked for indexing, although it didn't solve the issue with the photo app being unable to view files on those drives, or any app for that matter. I ended up reformatting C: and reinstalling windows. Apps and indexing are all working fine now...
    – Insarov
    May 28, 2013 at 18:41
  • Ah right. The Photo app will only show photos from the Pictures library (well and other places like Facebook and SkyDrive but not other drives). To get these photos to show up, you need to add the folder or folders with the pictures to the Pictures library. To do this: 1. Go to the Pictures library in File Explorer. 2. Click on 'Manage' from the menu bar under 'Library Tools'. 3. Then click on 'Manage Library' button. This will open a new window which will let you select folders to add to the Pictures library. Anything in these folders will show up in the Photo app.
    – Darcon
    May 28, 2013 at 18:48
4

If you press the WindowsKey+w, and then type 'index' in the search, you will see the 'Indexing Options' icon in the results column to the left. Open this and from here you can add or remove what is indexed.

Cool side note - this is where the Outlook indexing settings are too. :) Hope this helps.

1
  • I've already done that. The issue is that it's not indexing files from other drives, regardless of this option.
    – Insarov
    May 28, 2013 at 2:21
0

I ran into a thread (which was a different issue) that led me to "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search" in Regedit. The setting here you're looking for is "DisableAutomaticRemovableDriveIndexing". I set that it 0, then I stopped and restarted Windows Search service, and deleted/rebuilt the index. Also unchecked and rechecked all locations I wanted to be indexed beforehand for good measure. My A: and B: drives are now indexed. Hope this helps someone.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .