45

I'm using iTerm 2 on Mac, and whenever I press Command + Return the thing goes full screen. My big fat fingers can't help it, so I really need to turn it off. Any suggestions?

Thanks in advance

3
  • 2
    Waiting a few seconds for the stupid animation just killed it for me. (the animation is cool when you actually want full-screen).
    – Tim Harper
    Sep 5, 2015 at 7:02
  • 1
    Slack broke my brain training me to use Command-Return. I set iterm to ignore and then went to Slack and set "Show send button" off so I can train my brain properly again.
    – flickerfly
    Feb 1, 2019 at 17:30
  • 1
    Simply try restarting your brain Feb 18, 2019 at 10:43

2 Answers 2

74

Set Command + Return to Ignore in the iTerm 2 preferences.

Screen shot

4
  • 11
    Note, you have to add this entry using the + at the bottom. It isn't there by default.
    – studgeek
    Jan 20, 2017 at 20:21
  • Intuitive /s ...
    – ijoseph
    Sep 11, 2019 at 23:29
  • As of iTerm 2 version 3.3.6, it's under Preferences > Keys > Key Bindings (it's not labelled 'global shortcut keys' any more). Dec 29, 2020 at 22:30
  • If you set it to 'send hex code' instead of ignore, and set the hex code to 0x0D it will actually send the return char through to the terminal instead of just ignoring.
    – mrfred
    Jul 27 at 17:01
4

You can also change shortcuts from System Preferences:

Or by editing property lists:

defaults write -g NSUserKeyEquivalents -dict-add 'Toggle Full Screen' '^@f'
defaults write -app iTerm NSUserKeyEquivalents '{"Toggle Full Screen"="\0";}'
2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.