I am trying to install Voyage Linux on a 4GB compact flash card according to these steps. However it always fails at some point.

When I format the disk manually (as opposed to using the provided script) I sometimes get stuck at the mkfs.ext2 command with the message

Had trouble writing out superblocks.

Sometimes mkfs works but then tune2fs fails with:

tune2fs: Bad magic number in super-block while trying to open /dev/sdb1

Couldn't find valid filesystem superblock.

In that case I can sometimes run fsck -y until it finds no more errors, after which tun2fs will work.

But then it will fail while copying the system files to the disk. (I don't have the exact error message at the moment but it went something like "rsync input/output error (5)").

I tried using the dd command to check the card's integrity as suggested in this post. Reading works but writing zeros to the device fails with

dd: writing '/dev/sdb': Input/output error

Im doing all of this on Linux Mint 14 in a Virtualbox on Windows 8 (both 64 bit) and I am using an external USB card reader (Transcend TS-RDF8K). I can format the card to FAT32 and write on it in Windows with no problems. I also ran the Check Flash program on it, which found no problems.

Is my card broken and do I just need to buy a new one or is there anything else I could try first?


See if you have badblocks. If I understand correctly, there is no date to care about now on this flash card so you can do destructive test with badblocks. Don't worry. It will NOT destroy your flash card (it shouldn't!)> it will however destroy data on this flash card.

badblocks -wvs /dev/flshacard

Of course your dd test was similar... It looks like something is not right. You could try different (USB?) flash card reader.

  • Yes that's right, I don't care about the data on the drive. I ran badblocks and got this: "Pass completed, 2949360 bad blocks found. (104/1008785/1940471 errors)". I am guessing that means I should get a new card, right? – legr3c May 30 '13 at 7:08
  • I would say so, they are dirt cheap! Try another USB card reader just in case. – Chris May 30 '13 at 7:26
  • Ok, so I went ahead and got a new CF card since I don't have another reader available. I have the same problems with the new card, so it probably wasn't that. I also tried doing the installation from a Live CD instead of virtualbox but that didn't help either. So at this point it looks like it really is an issue with the card reader. I'm not really sure what to do about it now though, since I don't want to go and blindly buy new readers until maybe one works. – legr3c May 30 '13 at 13:32
  • Ask your friends. Check eBay - card readers are dirt cheap! – Chris May 30 '13 at 13:34
  • Got it to work now (see separate response). I should definitely have tried that earlier :). But thanks a lot for the help! – legr3c May 30 '13 at 15:17

Solved: Attached the card reader to a USB 3.0 port instead of a 2.0 port and everything suddenly worked like a charm.

I had to do the installation from the Live CD instead of virtualbox though, since the device does not appear in virtualbox when using the USB 3 port.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.