I would like to display current path in sh prompt (not bash shell), which currently just shows "#", I tried with introducing this

env PS1="$(whoami)@$(hostname):$(pwd)"

and

set PS1="$(whoami)@$(hostname):$(pwd)"

in /etc/profile.

But as obvious this does not refresh when the the directory is changed or user changes. Please suggest a way to make this dynamic.

  • 1
    Note that each $() runs a separate program; it would be faster to use environment variables, such as $LOGNAME, $HOSTNAME and $PWD instead. – grawity May 29 '13 at 12:00
  • One answer was to use single quotes instead of double quotes, however, that's quite the full correct answer. What you really want to do is defer evaluation of the code inside your prompt until the prompt is used. – MaasSql Oct 27 '14 at 14:40
  • All you need is to use export "PS1="$(whoami)@$(hostname):$(pwd) >" then edit /etc/profile and append this line at the end. – SDsolar Mar 29 '17 at 19:25
up vote 60 down vote accepted

Command substitutions in double quotes " get expanded immediately. That is not what you want for your prompt. Single quotes ' will preserve the substitutions in $PS1 which then get only expanded when displaying the prompt. Hence this should work:

export PS1='$(whoami)@$(hostname):$(pwd)'

If you want the usual dollar sign and a space at the end of your prompt, simply add $ at the end (no escaping necessary): export PS1='$(whoami)@$(hostname):$(pwd)$ '

  • 1
    Worked like a charm after changing 'set' to 'export' in your answer export PS1='$(whoami)@$(hostname):$(pwd)$' I saved the change s to /etc/profile. Thank you. – Bleamer May 29 '13 at 10:22
  • @Bleamer: set worked for me (but I didn't had a native sh). But I'll change it to export to comply with your setup. – mpy May 29 '13 at 11:01
  • 1
    Is there any way to make this permanent? Currently I have to do it each time I log in. Thanks! – the.ufon Sep 2 '14 at 7:07
  • 2
    You have put this line to /etc/profile (see question) or ~/.profile?! – mpy Sep 2 '14 at 16:39
  • +1, this would need some delimiter at the end, though. As is, you get something like foo@localhost:/home/fools -la when using ls -la. – phresnel Jan 6 '15 at 10:00
sh-4.2$ export PS1="\u@\h:\w>"
jenny@serenity:~>cd /usr/local
jenny@serenity:/usr/local>
  • 1
    I am afraid that works for bash shell not for sh, when i do this I get \u@\h:\w> as my command prompt – Bleamer May 29 '13 at 10:11
  • 1
    Must be a different sh version; as you can see from the first line, it worked for me in sh 4.2. – Jenny D May 29 '13 at 10:12
  • 1
    That may be the case. This shell is from Busy Box. Thank you. Appreciate your help though. – Bleamer May 29 '13 at 10:25
  • @Bleamer, it works for me with BusyBox v1.19.4 built-in shell (ash). – cjm Sep 11 '13 at 4:26
  • Thank you for response @cjm, though I'll avoid digging further into this. – Bleamer Sep 27 '13 at 9:34

This command works for me.

export PS1="\u@\h: \W:$"

Where
\u = username
\h = hostname
\W Name of present folder (not full path)

  • +1 for \W parameter – Dimitry K Oct 23 at 17:31

One answer was to use single quotes instead of double quotes, however, that's not quite the full correct answer. What you really want to do is defer evaluation of the code inside your prompt until the prompt is used.

set PS1="$(pwd)" 

sets the prompt to the working directory as of the set command.

set PS1="\$(pwd)" 

does NOT expand $(pwd). Instead, PS1 is set to the literal value of $(pwd).

Test / Understand this by running:

echo $PS1

. If you see the string : $pwd, your prompt works. If you see the literal path, the prompt is broken because it has been statically set

Use the below command to set is like in the cpanel.

export PS1='$(whoami)@${HOSTNAME%%.*} [$(pwd)]# '

  • Thanks! None of the other options above worked. This one did. Was driving me crazy. Thanks for saving my sanity. HA! – Lee_Str Jun 14 '16 at 12:57

One might consider to pimp the prompt by adding some colors. For instance:

export PS1='\[\e[0;36m\]\u\[\e[0m\]@\[\e[0;33m\]\h\[\e[0m\]:\[\e[0;35m\]\w\[\e[0m\]\$ '

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.