3

I have on my laptop a windows system (windows 8), in which I have a Virtualbox installation(4.2.12, most recent). I have a virtual machine setup with the Virtualbox, and the OS is Ubuntu (12.0 LTS). I connect an USB box (An adapter from SATA to USB) to my laptop, and the filesystem of the SATA disk in the USB box is Ext3. Now my problem is, I can't mount the USB drive inside the VM Ubuntu system, even invisible from /dev

I checked and confirmed that,

  1. Virtualbox supports USB 2.0, and my USB box is USB 2.0 version. (I have installed the Oracle Extention pack with the right version)

  2. My SATA disk (1 TG) works well with the USB box, for I connect it to a native (I mean not a virtualbox VM) Ubuntu system, it works!

  3. My Ubuntu VM works well as well, with an external USB drive. I tried/confirmed with a small USB drive with FAT32 FS.

So, what may I get wrong? Appreciate help!

(Edit, below is the error messages given by Virtualbox when trying to mount the USB drive)

Failed to attach the USB device USB Storage [0016] to the virtual machine water.
USB device 'USB Storage' with UUID {1ddcbf95-913c-459f-a6da-fc7331c3c62f} is 
busy with a previous request. Please try again later.

Result Code: E_INVALIDARG (0x80070057)
Component: HostUSBDevice
Interface: IHostUSBDevice {173b4b44-d268-4334-a00d-b6521c9a740a}
Callee: IConsole {db7ab4ca-2a3f-4183-9243-c1208da92392}
4

I have been dealing with this issue for a few hours now, here is your solution:

  • Windows - Right click on Oracle VirtualBox and 'Run as administrator'.

  • Linux - Open a terminal and open Oracle VirtualBox as root (ie. 'sudo virtualbox')

  • Mac - Do the Apple equivalent of running a program as an administrator (I have absolutely no knowledge of Apple products).

  • Once you have Oracle VirtualBox running as administrator, root, etc.. go ahead and create a USB filter as instructed by Nanobrains and vvlevchenko.

This process worked for me on Windows 8.1, I would hope that this process would work in virtually any environment.

1
  • 1
    the filter works.. as the vm starts the usb device is disconnected from host but fails to attach to guest (latest vbox 6.1) – Zibri Jan 8 '20 at 15:17
1

Please try to create USB filter in VBox GUI and physically re-attach USB hard drive.

2
  • 1
    I created the USB filter, and re-tried now, but still the same. Basically, what I did was, after I created the USB filter for it, I removed the USB cable and plug it again onto my Windows host machine - Is this what you wanted me to try by 're-attach'? – leslie May 27 '13 at 12:09
  • 1
    same here.. it disappears from windows and then vbox says it can't attach it. and it's just a pendrive. – Zibri Jan 8 '20 at 15:16
1

I have faced this problem very often with the virtual box. Go to settings page on your virtual box, go to USB, and add the USB filter, when you try adding the filter, it will show you a drop down of the USB devices connected to your laptop, choose one and add it. Once it is attached to your virtual Box, you will no longer be able to see it on your windows once you run your virtual machine. On closing the virtual machine, The USB drive appears back on the host machine.

0

My setup is Debian 9 x64 Host with Windows 7 Ultimate x86 Guest - VirtualBox 6.0

There were no errors being reported by my system - but I could not access or mount my USB drives in the Windows 7 Guest OS.

I tried USB filter editing, udev file editing, and an assortment of other tricks to no avail.

I don't know if it was necessary, but I closed the Guest OS, and VirtualBox, before executing:

sudo rcvboxdrv setup

Sources: virtualbox.org

I then rebooted the HOST computer and the USB drives were now accessible. There is no reference in the Oracle Chapter 02 document to solve USB access problems, but it worked on 2 different Machines with the same setup. Guest Add-ons and the proper Ext Pack were already installed - I don't know if the 2 additions mattered at this point. If you haven't done so execute this command - it is needed, - it will add your UserName to vboxUsers group.

sudo usermod -a -G vboxusers username

There is an explanation in the Oracle document instructing the reader to what the rcvboxdrv command performs. These are the steps I used to install virtualBOX 6.0 on my LINUX Host as a reference:

sudo apt-get update
echo "deb http://download.virtualbox.org/virtualbox/debian stretch contrib" | sudo tee /etc/apt/sources.list.d/virtualbox.list
wget -q https://www.virtualbox.org/download/oracle_vbox_2016.asc -O- | sudo apt-key add -
wget -q https://www.virtualbox.org/download/oracle_vbox.asc -O- | sudo apt-key add -
sudo apt-get install virtualbox-6.0
0

Given the same error:

Result Code: E_INVALIDARG (0x80070057)

I managed to solve this problem by deleting the following registry value:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000}\UpperFilters

You can delete it by hand using regedit.exe or by this PowerShell command:

Remove-ItemProperty -Path 'HKLM:\SYSTEM\CurrentControlSet\Control\Class\{36fc9e60-c465-11cf-8056-444553540000}\' -Name UpperFilters

After rebooting your system, passing through USB devices should work again.


Before deleting anything from the registry, you might want to make a backup of it.

If your system relies on the UpperFilters registry value, you should modify it instead of deleting it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.