37

Aspell version:

$ aspell -v
@(#) International Ispell Version 3.1.20 (but really Aspell 0.60.6)

Dump dict yields no results:

$ aspell dump dicts

First noticed the problem when I did this, was originally working on web server, but someone updated something and it hasn't worked since:

$ aspell check temp_test_file.txt
Error: No word lists can be found for the language "en_US".

What's the proper way of installing the required dictionaries? I believe we're running this on CentOS.

And also, /usr/lib/aspell-0.60 does not contain the required dictionaries (provided that they're supposed to be saved there).

data-dir: /usr/lib/aspell-0.60

33

If you've installed pspell/aspell via a package channel, the dictionaries may be available in another package. On CentOS 6 using default yum repositories, English dictionaries are in package aspell-en.

2
  • I can confirm this answer is also relevant on CentOS 7 and RHEL 7 (tested both). I should then be valid for aspell on OEL (as derived from centos) and scientific (derived from RHEL). – user2066657 Sep 3 '18 at 3:34
  • I had to get the epel repo before this worked. Detailed here: theshell.guru/install-aspell-centos-7-2 – Textcape Apr 27 '20 at 1:46
5

I had same problem on Fedora 22. I solved it by installing aspell-en.x86_64package.

5

Download dictionaries from here: ftp://ftp.gnu.org/gnu/aspell/dict/en/ Unzip it and do,

    ./configure
    make 
    make install

All the instructions are in README. This Makefile will find the correct locations that these dictionaries should go to.

1
0

I found that I had file permission errors with the make install step (as per the README instructions from the download above) and couldn't chmod the /sw/share/aspell/ directory. Running sudo make install got around the problem.

Hope that saves someone a headache!

-1

You need to install en-aspell. In FreeBSD:

pkg install en-aspell

2
  • 2
    OP's question was asking how to do this on Linux, not FreeBSD.... – joeeey May 13 '15 at 1:14
  • I agree. The package might have a completely different name in Linux, and the name could even vary between Linux distros. – jpaugh May 13 '15 at 4:02
-1

On macOS, my problem (as per usual) was that I installed it via some method other than Homebrew (brew install aspell and/or brew cask install cocoaspell).

Not the answer you're looking for? Browse other questions tagged or ask your own question.