I can't boot from USB even though the BIOS is set to boot from USB first. Windows Boot manager somehow seems to be taking precedence. I have Windows 7, Linux Mint and Ubuntu installed on my hard-drive. When I boot-up those are the only options, despite having a USB stick plugged in then going into the BIOS and setting the UEFI USB stick as the primary boot device.

The USB device is fine as I can see it in Windows/Linux and can read the files. I made it bootable (in theory) by using linuxlive and/or pendrive with no success (though I've had success with both in the past).

Any suggestions?

  • 1
    Did you try another USB port ? Did you try the stick in another machine? – Ofiris May 31 '13 at 12:41
  • Don't have another machine. I have tried all three ports. The drive stick worked before, but that was before I had installed Linux on the hdd and had to use windows boot manager. – Newb1 May 31 '13 at 13:04
  • I would try and remove the HDD from the Boot devices. If there is a problem with the USB device, it would tell you no OS was found. It sounds like currently, it tries to boot from USB and skips to HDD. – Ofiris May 31 '13 at 13:11
  • What's on the USB stick? Which BIOS do you have? I assume you're using Grub 2 for multi-booting at present? – Karan Jun 1 '13 at 6:35
  • Maybe your motherboard just don't support USB boot, it's totally possible, I have a few old PC that just don't boot on USB sticks... – Stakhanov Nov 20 '13 at 14:27

14 Answers 14

You need to enable booting from non-EFI devices. This option can be found in most BIOSs called the Compatibility Support Module or CSM. This option is sometimes hidden until you disable Secure Boot. I've also seen it hidden until Fast Boot is disabled. Once you enable the CSM module and set it to boot EFI + Legacy boot devices you shouldn't have any trouble booting your USB device.

  • What if I don't have this option? – William Jan 24 '17 at 2:06
  • @William Then you got unlucky. I have yet to see a computer without some "disable Secure Boot" or "CSM enable" or "legacy boot" or some sort of option to boot non-EFI or EFI-but-not-"secure" devices. – BenjiWiebe Mar 3 at 23:18

Your USB must have UEFI boot enabled. To do so, burn your ISO image to stick using Rufus (download here: http://rufus.akeo.ie/downloads/. Select 'Rufus V1.3.4'and download it. Open the tool and under partitioning Options select 'GPT Partition Scheme for UEFI computer'. Select your ISO from the small CD Drive Icon under format options. Click start. When finished reboot your computer and select the UEFI USB options from the manufacturer's boot options.

  • How do you fix "0 devices found" i.stack.imgur.com/tKPZ5.png error? – Pacerier May 1 '15 at 20:36
  • To top it off, before i did this, before it was GPT, i was atleast able to see the USB stick and browse it for UEFI files, now after following above steps the USB stick doesnt even show up in that list, wont boot even though its selected in bios ( i think i have to double check that since now its a gpt), and all i get is disk error, its not grabing the usb. ON first power on, it IS looking at the USB though, thats EXACTLY where it should be picking up.. wtf? – Brian Thomas Aug 28 '15 at 23:29

In order to boot from a USB drive UEFI, you have to have legacy boot enabled OR the drive has to be formatted in GPT.

I have an old computer, and I've had the same problem. I found a new solution for it:

  1. Go to this website and download the latest stable package (Plop Boot Manager).
  2. Write the ISO file into a blank CD
  3. Boot the computer from the CD drive
  4. Choose the USB option from the list

USB boot solution

  • Is there anyway to do this without CD? – Pacerier May 1 '15 at 20:38
  • this was exactly my problem. Thanks. – PKKid Sep 11 '15 at 2:09

I came across this post since I had a similar problem. i.e. my boot sequence in the BIOS was set to: Removable device, CD and HDD. I had my Windows 7 installation on a bootable USB sticked in, (no CD), but still it would boot in the OS from the hard disk drive.

Solution in my case:

The 16 GB USB stick I was using was not considered as a removable device. In the BIOS settings, I found that the problem was in the hard drive setting sections, so I changed the HDD setting from SATA to Sandisk. The BIOS setting was still Removable, CD and HDD, and this time it booted from the USB.

  • This was my problem on an Asus Express Gate P7P55D BIOS; the USB drive was listed as a hard disc, not removable media. I needed to remove the hard disc with the install I was trying to repair from the boot list. Thank you. – Dr Rob Lang Sep 9 '17 at 8:56

When you can't find the Compatibility Support Module (CSM), the legacy, and if Rufus seems too complicated and none of the other options in the answers listed here suites you, try a reset of your BIOS to "Optimized Defaults".

You just have to press a key, as indicated in the BIOS instructions. Mine was to press F9.

As soon as I reset the BIOS, it could identify my USB in a whole different way. Already as the first boot option and even the brand of the USB was there. So I pressed F10 and Enter to save and when rebooting it worked as predicted this time.

In this situation, it was a bootable USB created with Universal USB Installer from Pendrivelinux.com, according to this tutorial.

Either the USB stick isn't bootable, or you have EFI secure boot enabled, and the stick isn't secure boot enabled.

  • If he had Secure Boot enabled how would he be able to boot into Win7? – Karan Jun 1 '13 at 6:33
  • @Karan, doesn't Windows 7 support secure boot? – psusi Jun 1 '13 at 16:48
  • If you turn on Secure Boot Win7 won't boot. – Karan Jun 1 '13 at 22:10

The only thing you need to do to solve this error is to change the secure boot to off and change CMS boot to on and then set SATA configuration to the other one that is not selected.

I had this problem, and I'm presenting the solution:

  1. You need to make the bootable Windows 7 USB flash primarily. It is easy with Rufus.

  2. Restart the PC/laptop

  3. Enter the BIOS

    In the BIOS you must choose the option to boot from USB (in some BIOSes the option is USB-HDD).

In some BIOSes you need to rearrange the order of booting HDD also. Place USB as the first hard disk drive (USB flash is displayed by its producer name).

Also if you have a keyboard with USB port, you must enable "USB keyboard".

If the USB keyboard is not enabled at the step "Press any key to load from USB..." you cannot enter USB because the keyboard stops to function at this step if it's not enabled as USB keyboard.

  1. If you you cannot boot after these steps, your USB flash is damaged or your motherboard is very very old.

In my case of this exact issue I had created the bootable USB using a Microsoft tool and a Microsoft ISO image. I had used a USB 3 port on my machine to build the USB.

After failing to boot from it and trying all sorts of ideas, I simply plugged the USB into a USB 2 port, and it worked.

In my case of this exact issue I had to remove the hard disk drive power, boot from USB, and, while loading installation files, I repowered the hard disk drive.

  • Your answer is like a comment – yass Apr 30 '17 at 21:42

I had a similar problem with a Gygabyte mobo.

My fix:

  • Press F12 to enter the menu that allows you to choose boot order.
  • Noticed that there is '+' symbol in the front of 'HDD'.
  • Expand the selection and USB stick will be listed there.

I needed to press Esc on startup for my laptop with win 7 starter installed to boot from usb. This was after i selected USB as primary boot option in BIOS.

I had problems with booting from USB on a Gigabyte H55M-UD2h. I tried everything i could find, even easyBCD and DriveDroid. Every USB device i pluged in was visible but it couldnt boot.

Disabling onboard LAN PORT and making USB-HDD my first and only boot option resolved my problem. So if none of above help you, try that. Without disabled LAN i couldnt boot.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.