8

I have a laptop with a Hungarian keyboard, but I usually use a Finnish external keyboard. My problem is that very often windows tries to be smart, and it changes that layout of the keyboard on it's own, when I'm switching between apps, and very often it can be annoying that whenever I start typing I have to switch back the layout to Hungarian or Finnish, depending on if I'm using the build-in keyboard or the external ( I have to do the alt-tab combination).

So, is there any way that I disable that windows changes the keyboard layout on it's own?

7

Try that:

  1. Open control panel(Click Desktop Icon, take your cursor into the left bottom corner, right click, you will also find the control panel option or open Run box + R type control and Ok).
  2. Switch to all items view.
  3. Click Language.
  4. In the left hand side panel choose advanced settings.
  5. Uncheck the box under Switching input method that says Let me set a different input method for each app Windows.

enter image description here

  • 6
    That refers on the input method (i.e. handwriting), but not the input LANGUAGE. – Tamas Jun 3 '13 at 9:26
2

I had the same problem. The first part of @stderr answer is ok. But I had to do the following:

  1. Open control panel(Click Desktop Icon, take your cursor into the left bottom corner, right click, you will also find the control panel option or open Run box + R type control and Ok).
  2. Switch to all items view.
  3. Click Language.
  4. In the left hand side panel choose advanced settings.

Now this is the part that worked for me.

  1. Click on options enter image description here
  2. Click on advanced key settings

enter image description here

Here you can choose which keyboard shortcuts you use to switch between input languages. If you don't want to use it, select none. But now you know how to switch between inputs (if you look at which keys, default is left alt+shift)

Easy way to see which input language is chosen, turn on you language bar.

enter image description here

Now whenever you see the wrong characters you can see in the language bar which input language is currently in use.

  • Clicking on "Advanced Key Settings" tab in the last screenshot, allows you to change the keyboard shortcuts used to switch languages and keyboards. Set to (none) removes the keyboard shortcut from automatically switching keyboards/languages. You can still use Win + Space to quickly switch both. Either way if you use Adobe Products (Photoshop, etc) or Code Editors (Sublime, etc) you'll probably at least want to change the default key combos, if you don't want to remove them altogether. See also superuser.com/a/991729/659759 – SherylHohman Jul 4 '18 at 23:14
-1

The first part of the first answer is OK: Go to the control panel, go to “Languages,” check your language options. Underneath each language you see a line saying “Input Language or just Input.” Click on “change” or the existing language (dependent on the OS version).

A long list of languages appears. I clicked on “U.S. International” and applied it. Now one of my language options says: German, Input language: US English international, which is my default language. That will prevent the switch to different keyboard layouts. My OS is Windows 8.1.

In an intuitive OS, you would find this under “Keyboard -> Keyboard Layout” but Microsoft likes to play hide-and-seek a lot more than I do.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.