I'm having a strange problem getting internet connection on any of my 3 VM's I run inside of VMware Workstation. I'm running all three servers as bridged connections and the guest OS is Windows Server 2008 R2 on all three. The host computer is running a clean install of windows 7 ultimate x64.

When you hover over the the network connection in the task menu, it says it has an internet connection but I cannot browse to any pages, external or internal (router admin page). However, I can ping out to say google, nslookup google fine, ping other guest VM's, and my gateway. I cannot ping my host computer.

When I change my network adapter to NAT and change the adapter to get IP and DNS automatically it works fine. It will not work with NAT and the assigned IP I give it. But I need this work in a bridged configuration. I have also verified that I'm bridging to the correct physical network adapter.

I just replaced my old linksys wrt54g with a netgear wndr3700v4. When I put my linksys router back in, everything works great. When I put the 3700 in, can't get internet on the three servers. But here is the strange part, I think.

I also run VMware Fushion on my Mac Mini that runs a Windows 7 VM for my development with a bridged connection and this works perfectly fine with either router I have in!

HELP! Before I lose my mind!

  • Bridging to a client WiFi connection isn't supposed to work. If it did, we wouldn't need WDS (we'd just bridge like we do with wired connections with no special configuration needed). It sometimes does because devices violate the WiFi specification, but it's officially not supposed to work. The VMs are not clients of the access point, so the access point is not supposed to broadcast their traffic to its clients because that wastes bandwidth and creates security risks. (At least, that was the thinking when the early, slow and insecure WiFi specs came out and we're stuck with it now.) Jun 3 '13 at 0:27
  • @DavidSchwartz Thanks! You're right! I was setting up the server using a USB wifi adapter before I moved it into it's permanent location. Once I connected it using a wired connection, everything worked fine. I appreciate your response!
    – robson
    Jun 3 '13 at 13:22

It's hard to give you a definitive answer from the description, but...

If I were you, I'd check the security settings on the wndr3700v4 and see if there was anything in there that might be blocking you. For example, googling says they disable IPv6 by default.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.