This seems to be an extremely difficult problem—it has already defeated two other IT professionals, though I'm not sure if they've come as far as I have. I'm trying to get a SHARP AR-M237 printer to work with a computer running Windows 8 (64-bit). The printer works fine with Windows 7.

Clearly, in order to make the computer recognize it we need a driver. So I went to the company's website and tried a few different kinds of drivers: http://www.sharpusa.com/customersupport/productdownloads.aspx

There is no official driver for Windows 8, so the one I will be discussing here is the Windows 7 64-Bit PCL6 Driver for AR-M237. (Just select "Printers & Fax Machines" -> "Model Not Listed" -> AR-M237 -> "Driver" -> "Microsoft" -> "Windows 7 64-Bit" to download a copy for yourself.)

It seems possible to trick Windows 8 into using a driver made for Windows 7. I found the same tutorial from a couple different sources, so this appears to be the correct method for doing so: http://www.pcpro.co.uk/blogs/2012/08/06/getting-older-drivers-to-work-in-windows-8/

The tl;dr here is that we need to modify the driver's .inf file in order to make it work properly and then do some sleight of hand to make Windows 8 accept our modifications.

Only problem is that there is no .inf file for this driver. Instead, there is a .inx file, which apparently spits out a .inf file specific to the operating system that the driver is being installed on during setup. Makes you wonder why they even gave you a separate download link for each OS.

My immediate response was to try opening up Setup.inx in a text editor (tried Notepad first then Notepad++). That gave me a bunch of byte soup, which looks like so:


Incomprehensible, as if I'd just opened up a .jpg in Notepad.

Next I tried Adobe InDesign CS6, which is the program that .inx files are supposed to be compatible with. I got this error message:

Cannot open the file "Setup.inx". Adobe InDesign may not support the file format, a plug-in that supports the file format may be missing, or the file may be open in another application.

It didn't show me anything after that.

So then I tried Microsoft Visual FoxPro 9.0 after doing a little research. When I tried to open Setup.inx, I got a message window with the heading "Program Error". This was the text:

Unrecognized command verb.

It then showed me the byte soup I had seen when opening this file in a text editor.

Then I tried Microsoft Visual Studio, which gave the most promising results. When I opened Setup.inx in Visual Studio, I saw 16 columns of data (with a column of byte soup on the right), which looks like this:

74 C4 2C 84 E1 E5 D4 28 10 FB 00 20 3C 24 FB 4D

Maybe that's what opening a .inx is supposed to look like, but if so then it's really too low-level for me to do anything with it.

Looking again now, it seems that there is a setup.ini file that can be opened and edited in a text editor, but it doesn't seem to contain the kinds of information that the tutorials for modifying .inf files talked about. I could be wrong. Same thing with setup.sii. I'm not even sure what that setup.isn file is all about—it opens as byte soup in text editors too.

I don't know what move to make next other than Ask the Internet. A million thanks to anyone who can help me figure this out.

  • 1
    Stop meddling with the files, fitting a square peg into a round hole. Contact support. – Deer Hunter Jun 2 '13 at 12:19

You probably need InstallShield Admin Studio to be able to do anything with a setup.inx file. You certainly aren't going to have any joy continuously opening it in other random applications. It's clearly a binary file, so why waste time with it?

Contact the vendor is the only sensible option here. If the vendor isn't supporting Windows 8, stick with Windows 7 or find an alternative device that does support Windows 8.


Use the print driver for Sharp AR-5625 that is in the list of printers in Windows 8/10 and it should work, did for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.