0

I encountered a...glitch where I seemed to have changed my keyboard language in Notepad++. I fixed the issue with this Q&A. How do I prevent this from happening again?

1

As I was typing the above, I realized that I still had the problem in a form: it was not fixed in Firefox. Apparently, I had not just changed my keyboard language in Notepad++, but in my system in general. While Ctrl+Shift worked in Notepad++, I had to use Alt+Shift to fix it in Firefox.

I found out a lot more about this issue at http://www.daniweb.com/hardware-and-software/pc-hardware/usb-devices-and-other-peripherals/threads/94301/help-my-keyboard-does-french-instead-of-question-marks, including how to disable the accidentally triggered hotkey that altered the keyboard language.

There was a (default) hotkey combo set when I installed Windows 7. I disabled it by going to

Control Panel -> Region and Language -> Keyboards and Languages

click on Change Keyboards...

select the Advanced Key Settings tab

You can set or disable the hotkeys here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.