I am seeing an issue with VMware Workstation (9.x) when using the host OS ( Windows 7) where pinging a local server on the same subnet or elsewhere on the LAN will occasionally result in Destination Unreachable errors from the 2 VMnet adapters, after which the LAN adapter will successfully ping the remote server. I have the LAC (primary internal NIC) adapter as the highest priority in adapters and bindings but the problem will still happen frequently unless I disable the VMnet1 and VMnet2 in Network Connections.

Summary: When pinging a remote server from the host OS, ( the problem is NOT a virtual machine, it's a physical machine that happens to have VMware workstation installed) which has Vmware Worstation installed: VMware Virtual Ethernet Adapaters seem to be ignoring the adapter order and jump to the top of the list causing destination unreachable failures on both VMnet adapters, before rolling over to the Local Area Connection NIC which successfully pings the server.

  • Where are you adjusting the priorities of adapters and bindings? In Windows or in VMware? – Coldblackice Jun 4 '13 at 1:51
  • Windows. The problem I am having is a Windows OS issue with the Host OS (not a virtual machine) it just happens that I believe VMware, or more specifically the virtual adapters created by VM ware are the cause of the problem. – Gregg Leventhal Jun 4 '13 at 15:51
  • Any update on this? Were you able to find any resolution? Did the answer below help any? – Coldblackice Jul 4 '13 at 22:58

Without further details of your setup, here are two routes of possible solution:

1.) Manually set the NIC/network adapter metric(s):

The usual suggestion for adjusting network adapter ordering/preference/metrics is adjusting the order of adapters in "Advanced Settings" of the network adapters control panel (in Windows). In this box, one can move respective adapters up or down the list, parallel with the equivalent ordering of adapter preference.

However, there are other system variables and factors that come into play with the network metric of a device --


Manually set the network metrics. In the network adapters' properties and protocol configuration, under "Advanced", there's an option called "Automatic metric". Find this property for the devices you wish to be non-primary, uncheck "Automatic metric", and then manually set the metric, adding +1000 to the metric box. Restart the adapters/network stack, and then see if the problem persists.

2.) Managing VMware's network configuration

In VMware (VMware Workstation), there's a submenu of network configuration called "Virtual Network Editor". It's accessed through the "Edit" menu on the toolbar.

Inside that configuration window, select the appropriate VMnet# that you're needing to adjust, and then set the specifics of that VMnet adapter in the panel below (e.g., bridged vs. NAT, automatic settings, etc.), according to the manual metrics you've appropriately set on other respective adapters (virtual and physical) in your system.

My best hunch is that this issue is a matter of automatic metrics being set. There are many different variables that come into play with these metrics, and you'd be best served by at least initially setting the individual metrics manually to narrow out any automatic-configuration tomfoolery.

Now that I think about it, a tool that lists the current network adapter metrics "live", along with showing who/what is sourcing a particular adapter metric change, would be most helpful, indeed! I'm not sure if a tool like this presently exists.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.