22

I've tried using VAC virtual audio cable, as well as virtual audio streaming. Unfortunately, none of these solutions provide a way to send audio output to a microphone input. None of the virtual audio cable related posts on here or internets address this specific limitation.

The reason I want to do this is to stream audio to the microphone and set the microphone as input device for another program. This "other program" only allows microphone inputs to be used as its input device.

See how no mic's are listed as output devices:

enter image description here

There is a software called Solicall which actually allows this. But I would like to do this through VAC virtual audio cables because Solicall only allows one instance running. Thus, I can't do my audio routing method more than once simultaneously. I have yet to find a better solution however than Solicall.

Someone please post if you found a way to do this with virtual audio cables, or any solution more elegant than Solicall. Currently, all the virtual audio cable programs I've tried do not allow microphones (real or virtual) to be selected as output.

0

6 Answers 6

6

Maybe you should give a try at Jack. It allows all types of virtual cabling. Jack is better on GNU/Linux and Mac OS X, but it seems it's possible to run it on Windows.

Maybe Pure Data can be interesting too.

6

It works natively for me in Windows 10 using this Set output audio of windows as input audio of microphone

Try this:

Go into the "Sound" control panel applet, (e.g. Start -> Run -> mmsys.cpl)

select the "Recording" tab,

Then right-click on and enable the "Stereo mix" device.

(If "Stereo Mix" isn't being shown, then right-click in the white space or on one of the listed devices and ensure that "show disabled devices" is enabled)

You should now be able to set that Stereo Mix as a source for recording. i.e. it should show up now as an alternative "input" or "microphone" device in the app you are using.

1
  • 3
    This does not work (anymore?). There is no "stereo mix" device for me, either disabled or disconnected. Feb 13, 2022 at 1:31
4

If you are on a Windows system, consider Voicemeeter.

Voicemeeter is Audio Mixer Application endowed with Virtual Audio Device used as Virtual I/O to mix and manage any audio sources from or to any audio devices or applications.

2

I had this problem recently with Rosetta Stone. It only allowed you to choose inputs marked as a "Microphone".

Virtual Audio Cable supports marking cables as Microphones. You just have to select the cable you want to edit in the Virtual Audio Cable Control Panel (vcctlpan.exe) and then check the box that says "Mic" in the top right corner.

Make sure you run the control panel as administrator to make changes

If the program still does not recognize anything then I would try reinstalling the program itself and/or Virtual Audio Cable. Beyond that you will need to be more specific about the program for me to give you any more suggestions :)

0
2

Try just plugging an AUX cord into both the input and output of your computer. This is what I used when I wanted to record let's plays. The downside is that this ties up your output. It wasn't a problem for me because my computer had multiple outputs. If you only have one output you could get another but getting a USB soundcard.

USB soundcard for $6.

Here's an AUX cord for $1.

1

https://vb-audio.com/Cable/

Try this. It works very well. The only problem with this setup is, you can not hear the audio that's being sent to the mic.

1
  • 1
    Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Oct 2, 2022 at 16:59

Not the answer you're looking for? Browse other questions tagged .