129

The question is pretty much in the title. Windows 8 is restarting, I probably only have like 13 minutes by now, but I can't have my computer shut off, doing like 20 different things on a couple of different VM's. How can I stop this?

I found these instructions, but I'm not sure if it will stop the process if it is already taking place. http://www.howtogeek.com/139993/prevent-windows-8-from-restarting-your-pc-after-windows-updates/

In the link mentioned above, I can disable auto update through group policy or through registry editor.

regedit seems like it requires a reboot, but it doesn't specify with group policy.

  • 11
    NOOOOOOO... it restarted, and was back up and running in like 20 seconds. But I did lose everything. Note to everyone else, changing group policy and force updating group policy doesn't work. Also, shutdown /a did not work. – EGHDK Jun 3 '13 at 20:45
  • 1
    Next time (if it happens) try opening notepad and typing something in. Windows will send a close message to Notepad and ask if you want to save or cancel. Cancel should stop the shutdown, but if the signal went to other apps first, they might close before you cancel. – Keltari Jun 3 '13 at 20:51
  • 3
    I had a couple of unsaved things, it just instantly killed everything and said "Restarting..." – EGHDK Jun 3 '13 at 20:54
  • 1
    admin command prompt, shutdown.exe /a followed by running services.msc and disabling the Windows Update service. After that it might be something besides Windows itself. (Corporate IT often has it's own thing that will apply hotfixes and reboots.) Update: shutdown /a did nothing huh? Hmm. – Mark Allen Jun 3 '13 at 21:41
  • 1
    @Ramhound The OP didn't say that Windows wanted to restart 15 minutes after booting. The two days have certainly elapsed. – xehpuk Mar 13 '15 at 23:21
111

One quick way to reset the timer, is to lock your computer (WindowsKey + L). Your computer won't restart if it is locked. You can then either logon again (giving you valuable time to save the things you want saved), or stop the update service all together.

Prevent imminent reboot:

WinKey + L (Lock your computer) and log on again

Then you may decide to postpone rebooting until you do this yourself by stopping the update service. Fastest way to stop the update service is using PowerShell or a commandline:

PowerShell:

Stop-Service wuauserv

Cmd: (Run as admin)

NET STOP wuauserv 

Note that resetting the countdown stop by locking the computer might be disabled if update 2835627 was installed (by either yourself or your friendly administrator). See http://support.microsoft.com/kb/2835627/en-us for more details.

To prevent auto rebooting while logged on, please see http://support.microsoft.com/kb/555444/en-us for a registry hack.

Be aware though that auto rebooting was not designed to give you a hard time, but rather because it is very necessary from a security point of view.

  • 16
    NET STOP wuauserv doesnt seem to work, I stopped the service but am still getting the countdown dialogs. – jdm Jun 19 '14 at 15:47
  • 10
    None of this advice works anymore. It used to. Apparently Microsoft REALLY wants us to reboot. The 15min timer is a real problem when it's a workstation I haven't booted in 3 weeks and I'm half way into a 1.6GB video upload when it chimes in. – Imperative Feb 21 '15 at 23:36
  • 4
    @Imperative It's really great that they start that 15 minute timer after I have been on the system for three and a half hours and am ass-deep in some code. Great job Microsoft! – 410_Gone Jun 17 '15 at 14:43
  • 2
    NET STOP wuauserv works so long you run CMD as admin - +1 – Pakk Jul 14 '15 at 14:23
  • 6
    This is, beyond all possible debate, the #1 most infuriating "feature" I have EVER encountered on any device ever. It's actually designed to just completely f**king destroy everything you're working on, but not until it taunts you with a short timer, with absolutely no way to stop it. Oh, and it will often do this randomly when I walk away from my computer for a minute or two; can't tell you how many times I've stood up for 'stand up' in our agile development team, only to peak back at my computer a minute later and see that it has randomly restarted itself. REDICULOUS. – Triynko Mar 31 '16 at 22:54
28

The safest solution to prevent Windows update from automatically restarting your Windows 8 (or later) machine without disabling Windows Update or messing around with stopping services is as follows:

  • run gpedit.msc
  • browse to Computer Configuration\Administrative Templates\Windows Components\Windows Update
  • edit No auto-restart with logged on users for scheduled automatic updates installations
  • set it Enabled

Note that this isn't going to stop a timer that has already started. Once upon a time you could use shutdown -a to stop a shutdown timer, but this doesn't work in this instance. If you've currently got a timer up and you desperately need a few more minutes, stopping the Windows Update service until you're ready is probably the way forward.

  • That setting was already set to Enabled when I looked at it, and yet I still got this 15 minute forced restart. And I had just restarted a couple hours earlier. First time I've ever had it force me to reboot since I installed windows 7 on this pc several years ago. – fantabolous Aug 31 '15 at 3:40
  • 1
    Yes, MS apparently think it's ok to ignore explicit user settings. They go even further and actively revert your decisions for you. I found a guide to disable automatic reboots and it involves revoking write permissions from SYSTEM for a certain key file. We have to actively deny some permissions to SYSTEM because if we don't, it will screw us over! Damn MS get your act together this is really unacceptable! – Stijn de Witt Oct 12 '16 at 17:49
  • Worth pointing out that there are 2 other settings in that same group: "Delay Restart for scheduled installations" is set to 15 minutes, and "Re-prompt for restart with scheduled installations" is set to 10 minutes. They can be changed to say 600 minutes or whatever you prefer. As pointed out in other replies, this does not alter an ongoing timer. "net stop wuauserv" in an admin cmd combined with killing "wuauclt" take care of that. – ralfoide Oct 14 '18 at 18:04
21

Since time is of the essence here, literally, I would try this:

Temporary Workaround:

Run this command from CMD net stop "windows update"

http://www.techspot.com/guides/230-prevent-automatic-windows-update-restarts/

  • Windows 7, that. – Nick T Jun 3 '13 at 20:42
  • 6
    Right as I was typing it in, my computer shut down. Now the world may never know if it works for Windows 8. – EGHDK Jun 3 '13 at 20:45
  • Oh well, let's hope not too much was lost eh? – Michael Frank Jun 3 '13 at 20:48
  • 3
    Confirmed to work - though I disabled it using services like the other answer. It's all the same. – SpartanDonut Jun 16 '13 at 5:55
  • Good to know. :) – Michael Frank Jun 16 '13 at 20:46
19

It appears that the answer to this question is evolving as Microsoft keeps making it harder to put off restarting.

This answer was gleaned from many of the other answers and comments to this question.

The solution to stopping restart involves two stages, first stopping the Windows Update service, and second stopping the Windows Update process.

To stop the service open Task Manager (Hit Win - R then type taskmgr).

  1. Click on the Services Tab
  2. Find and highlight the row with the Name wuauserv and Description of Windows Update.
  3. Right click and select Stop to temporarily stop the service.

enter image description here

Next we need to stop the Windows Update process.

  1. Click on the Details tab in Task Manager
  2. Find and highlight the row with the Name wuauclt.exe and Description of Windows Update.
  3. Click End Task

enter image description here

This will stop the 15 minute countdown, but Windows will automatically restart the Windows Update service and start another 15 minute countdown in a couple of hours unless your restart your computer. At which point you can go through the procedure and halt the countdown again, but this is really a temporary solution to enable you to finish what you are doing and restart your computer in an orderly manner.

  • 3
    This should be the top answer; everyone has been talking about how to stop this happening using Regedit and GPEdit but they major issue is how to stop a countdown if a countdown has already started. As others have noted, shutdown /a no longer works. Stopping the service also doesn't seem to stop an active countdown timer anymore. Killing the process is the way! – jwbensley Aug 9 '17 at 7:28
  • 1
    While this may be temporary, this is the only thing that works in 8.1. – Trinidad Apr 14 '18 at 22:31
10

Run the cmd as Administrator and type:

NET STOP wuauserv
  • I have just attempted this; it tells me "The Windows Update service could not be stopped." This is at an Admin command prompt. Guess there's just no chance of avoiding MS's super important scheduled restart... – Keiji Sep 25 '16 at 21:35
6

In Windows 7 you can stop this timer by stopping the Windows Update service in the services MMC snapin (services.msc). Try if this still works in Windows 8.

5

I found by setting the clock back on my computer (right click time in bottom rt. corner -> adjust date/time) by a day it seemed to fool the automatic restart system.

3

Apart from above you can try this : type Win+R - > regedit and Goto path 'HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU' in regedit If path is not present then create the same Now add DWORD (32-bit) with name NoAutoRebootWithLoggedOnUsers Add data value 1 with hexadecimal base. Close the registry editor and run gpupdate /force with administator rights.

Another way is by using group policy: type Win+R - > gpedit.msc -> 'Computer Configuration\Administrator Templates\Windows Components\Windows Update'

"No auto-restart with logged on users for scheduled automatic update installations” setting. Set the setting to Enabled and click OK. Close the group policy editor and run gpupdate /force with administator rights.

  • what does gpupdate /force do? – YumYumYum May 29 '15 at 12:36
  • it refreshes local and Active Directory-based Group Policy settings, including security settings for user – zehnaseeb Jul 2 '15 at 15:04

protected by Community Nov 23 '14 at 23:32

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.