I'm trying to save a Word document as .docx, but each time I click the 'Save' button the dialog reappears and asks me where to save the file. This only happens when I try to save it as a .docx file, any other format works just fine. I have tried pasting the contents into a new file, but the same happens.

I really need the functionality from .docx though, since there are quite a few formulas in the file.

The version I use is Word 2010.

  • Does your default template contain any macros?
    – Adam
    Commented Jun 4, 2013 at 7:35
  • @Adam it does not. As far as I know it's the default template that is installed with Word. Commented Jun 4, 2013 at 11:00
  • 1
    @SimonVerbeke - Sounds like you are trying to save a read-only file.
    – Ramhound
    Commented Jun 4, 2013 at 11:52
  • I did some more troubleshooting, and it seems like Word is having issues trying to save a formula. Commented Jun 4, 2013 at 15:12
  • 3
    Too late to edit my comment. I retyped all the formulas in a new document, and now it saves without issues. Commented Jun 4, 2013 at 15:26

23 Answers 23


Answer from comments in OP:

I retyped all the formulas in a new document, and now it saves without issues.

  • you can save a lot of work with the following trick. In my case, it was just one small formula among lots of others. So, I just copy pasted the whole document into new document and by trying to delete some of the formulas and save the document I found very quickly (by sequential halving) which formula causes the problem. And it was just one single letter formula among many others, much more complicated formulas :-)
    – Tomas
    Commented Aug 20, 2018 at 10:52
  • 2
    it happened again, and again, it was caused by just due one formula! Copy paste the whole document into new one and sequentially delete various formulas and see when saving starts to work. You don't even need to retype the problematic formula! Just copy paste it to new word document, delete it from the original document and paste it back. Voila!
    – Tomas
    Commented Aug 20, 2018 at 19:06

It's a Word bug. It sometimes manifests itself when working with formulas and affects versions 2007 and 2010, possibly newer ones too.

To avoid re-typing formulas or saving in compatibility mode (which converts formulas to images):

  1. Install a clipboard manager (Ditto Portable is a good one and you don't have to actually install it, it's a self-extracting archive).
  2. Switch to Word, press Ctrl+A to select everything and copy it.
  3. Use clipboard manager to export clipboard to a file. Clipboard should be preserved anyway, but do it just in case.
  4. Close all instances of Word. Copying everything to a new instance will work, but you need a full Word restart first. It may throw some errors when closing the last window, ignore them. Kill it with Task Manager if needed.
  5. Open Word and paste your document. If it's not in the clipboard anymore, import it with clipboard manager first.
  6. Saving as docx should now work.
  • Ditto portable doesn't work for me on Win XP :/ Just exits immediatelly..
    – Tomas
    Commented Aug 20, 2018 at 10:53
  • 1
    Fortunatelly you don't even need any clipboard manager, see my comments on Dave's accepted answer. You don't even need to close Word.
    – Tomas
    Commented Aug 20, 2018 at 19:09

I finally fixed this by simply following the "Open and Repair" feature in MS Office 2013 (probably in 2010 as well). Check it out - http://support.microsoft.com/kb/893672. This told me my errors (text box and a shape).

Afterwards I put my 2010/13 styles back on while in 2013, saved, and everything took. I hope this helps.

  • The "open and repair" created a new "Document 1" with the content of my doc, but stll unable to save (Office 365, Windows 10).
    – Jonas
    Commented Sep 20, 2017 at 4:21
  • how can you use "open" when the file is not saved yet? The problem here that the file could not be saved in the first place.
    – Tomas
    Commented Aug 20, 2018 at 10:22

I've just struck a very similar problem --- could save the document in 2003 (.doc) format, but trying to save in .docx resulted in an endless loop of SaveAs dialogs popping up, and no document actually being saved.

The document had pictures but no formulas, and and first I didn't have a clue which parts of the document were corrupted.

If it helps others, I was able to fix the problem by doing the following:

  • With an open document, choose Save As.
  • Set to save in .docx format.
  • [Very important!] Tick the box titled “Maintain Compatibility with Previous Versions of Word”. Word then allowed me to save the document, but indicated it'd fixed some errors. At this point, I could click the Details button for a list of errors which had been fixed.

This enabled me to save a document in Word 2010 format. The document was saved in Compatibility mode, but I could easily revert that by choosing File/Info/Convert to convert it to a full 2010-format document.


I had this issue when I was using a auto-Bibliography with the IEEE style.

I had to remove the bibliography from the document to get it to save.

It saved, but I'm not sure what will happen if I try to add the bibliography back in.

  • Thanks, this resolved the save loop for me. I could save once I removed the bibliography, but the loop re-appeared when I put it back. I could put it back after I restarted Word though. In any case, didn't have to copy the content to another document.
    – Artyom
    Commented Aug 3, 2014 at 18:12

In my case it was 'track changes' that was effecting saving my document.

I had four documents that i need to put into one - all with numerous track changes on them. Removed the track changes on each document, pasted them into one document and I was able to save after this.


I had this same problem in Word 2013. Turns out they let you insert an .ico as a picture, but after doing so I got the endless save loop. Took me a while to find the problem, but after taking out all the icons it saved just fine.

Hopefully that's useful for somebody stumbling across this question in the future.


I have an alternate solution for this bug - not perfect, but in my case I could save the whole document:

The issue comes from formulas, tables or the like. Make a new Word-Document and copy and paste the text,formulas in parts step by step. Try to save after each pasting. Change or retype the actual part, if the save loop starts again.

In this way I could save a big document with formulas etc.

I hope it helped and excuse the english-grammar mistakes ;)

Good luck!

  • 1
    +1 You can potentially save some time via bisection, i.e. copy paste half the document, depending on whether it works or not you know that this half has a problem or not, if yes, half the half etc Commented Oct 1, 2014 at 11:37

In WORD 2010, if a formula or the text that serves as the target for a table of contents is edited and is left in red-line track changes mode, this can cause this same behavior in the WORD file. Simply undoing or accepting the tracked changes in the formula or regenerating the table of contents can fix the problem.

  • 1
    The tail end of your first sentence ("this can cause this same behavior in the WORD file") is hard to understand. You may want to consider clarifying what you mean (by editing your answer).
    – lzam
    Commented Sep 28, 2014 at 21:15

In my case I disabled the save option "Allow background saves". This resolved the issue on Windows 7 with Microsoft office 2010.

Path for "Allow background saves": File ---> options --> Advanced --> save

  • This worked for me too with Word 2013 on Windows 7.
    – Alex Quinn
    Commented Nov 11, 2017 at 2:14

In Word 2013 I Opened the file that was not saving. Click on File tab and then select Info. I selected Check for Issues and then selected Inspect Document. This listed some potential issues and gave me a choice to resolve specific issues that were identified. After resolving the issues I was able to save my document again.


In my case it was a table of contents. I just removed it, saved the document, and recreated the table of contents. Cheers


In my case the thumb drive where I had been saving the file got damaged. Strangely, I couldn't save it elsewhere as a Word file but I could as an RTF. Repairing the thumb drive (using windows tool) fixed the problem and allowed me to save as a word file.


I tried everything here but nothing worked apart from this solution:

Whenever I wish to create a new MS word document and use it, I do not use previous templates. I make a folder and right click inside the folder to choose the New Microsoft Word Document option from the drop down menu and work on that.

I do not use any previously saved templates and do copy paste of the docs that I build, I make a new MS word doc by using the right click option and work on it. I rename it according to the topic that I write on.

The save loop never comes up now and there is no compatibility issue error or other problems like Shift key not working with some other keys.

  • So you suggest this is a problem of templates? Commented Oct 1, 2014 at 11:37

Suddenly word started preventing me from saving. I always had images and formulars in the document, but what with Microsoft products having a mind of their own, it decided to start being an idiot.

A simple solution for me was to save the doc as rich text format (rtf). Close windows. Open the file and re-save as doc.x


I faced similar problem and wasted more than 2 hours trying to fix it. Finally saved the file as .DOCM and it saved then just saved as .docx No problems.


Also try turning your Preview Pane in explorer off (Under view tab) - none of the above worked for me until I did this. The preview pane puts words into read only mode automatically.


None of the above worked for me on my new laptop running Windows 10 and Office 2010. What did work was removing the trial version of Office that came with the laptop. I did this using Control Panel, Programs, Programs and Features, selecting the relevant version of Office, right clicking and selecting Uninstall.


I had the same problem, while I did not have any functions in my file. I had copied graphs from Excel to Word, after which Word got this saving loop. I copied each graph and pasted it as an image, so there is no link to Excel any more. After that, Word saved fine again.


None of these worked for me either, I could fix it by closing down word then go to taskmanager (control + shift + escape) then shut down all Microsoft Word processes. Then restart office and it should work fine.

I hope it will work for you guys!


I solved my issue with this as follows:

I had several hundred pages of statistical equations and multiple pictures. I wanted to edit my document but it was failing to save all the time, so I saved an unedited version of my file as a Word 1997-2003 document. This made all the equations turn into images.

Then, I reopened the newly saved document, selected all and copied it into a new Word 2016 document. The equations were no longer images and I successfully edited and saved the document. I hope this works for all - I lost roughly a day till I did it right.


This is how i managed to save a large document that wouldn't save anymore. Basically start word with the /n command line parameter.

E.g. Press Win+R to run 'winword /n'

Basically the word process I was using was messed up and by starting a new fresh instance I could do anything like copy all the contents to a new document and save again without the error coming up or a save loop. I'm very happy i saw that parameter here: https://stackoverflow.com/a/5732041/40961


Though this mightn't be the problem faced in the original question, in my case saving also went into a loop (and couldn't even open save-as): the problem, and hence solution, was the max path length (of 255 or 260 characters).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .