1

I have an mdadm RAID 5 array running on Debian Wheezy. It's comprised of 3x 2TB drives.

I've obviously done something stupid, because now I can't mount it and it's throwing up the following error:

mount: wrong fs type, bad option, bad superblock on /dev/md0,
   missing codepage or helper program, or other error
   In some cases useful info is found in syslog - try
   dmesg | tail  or so

As my luck would have it, I was about to do a full backup in the next day or so (as it always goes). I'm starting to freak out a little bit, so I'm hoping someone can help me out.

The array has an ext3 filesystem on top of it, if that makes any major difference.

After doing some Google Fu, I tried running fsck -n /dev/md0, which returned the following (link because I figured you wouldn't want 640 lines here):

http://pastebin.com/ewCYn1u6

Obviously I'm going to have to do something about this, but I'm not entirely sure what effect forcing an fsck on the filesystem would have (I don't want to just make things worse). What should I do?

If you need any more info, let me know.

1

As it turns out, it was a filesystem issue, rather than an array issue (the array was still fully functional). The filesystem did not unmount cleanly, so it was corrupted.

Luckily, running fsck seems to have fixed it with no apparent data loss. YMMV.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.