I tried to upgrade Foxit Reader and it left the directory in an unreadable state. I can't view the directory, nor even delete it, not even as Administrator. How do I get rid of it so I can re-install?

C:\Program Files (x86)\Foxit Software>takeown /f "Foxit Reader"
ERROR: Access is denied.

C:\Program Files (x86)\Foxit Software>takeown /a /f "Foxit Reader"
ERROR: Access is denied.

C:\Program Files (x86)\Foxit Software>icacls "Foxit Reader" /setowner Administrator
Foxit Reader: Access is denied.
Successfully processed 0 files; Failed processing 1 files



Even ran chkdsk, which found no problem:

C:\Program Files (x86)\Foxit Software>chkdsk
The type of the file system is NTFS.
Volume label is OS.

WARNING!  F parameter not specified.
Running CHKDSK in read-only mode.

CHKDSK is verifying files (stage 1 of 3)...
  643840 file records processed.
File verification completed.
  7590 large file records processed.
  0 bad file records processed.

CHKDSK is verifying indexes (stage 2 of 3)...
  819780 index entries processed.
Index verification completed.
  0 unindexed files scanned.
  0 unindexed files recovered.

CHKDSK is verifying security descriptors (stage 3 of 3)...
Security descriptor verification completed.
  87971 data files processed.
CHKDSK is verifying Usn Journal...
  36537832 USN bytes processed.
Usn Journal verification completed.

Windows has scanned the file system and found no problems.
No further action is required.

 961180671 KB total disk space.
 283748976 KB in 547635 files.
    271996 KB in 87972 indexes.
         0 KB in bad sectors.
    778755 KB in use by the system.
     65536 KB occupied by the log file.
 676380944 KB available on disk.

      4096 bytes in each allocation unit.
 240295167 total allocation units on disk.
 169095236 allocation units available on disk.
  • 1
    Try to find out if any process has a file handle on it, among others you can use sysinternals process explorer. – Martin Jun 6 '13 at 20:08
up vote 6 down vote accepted

The problem was Brother Control Center had a lock on the file. I don't know why Brother Control Center was running - I did not run it, it does not start at boot - but it had a lock. I killed the process and the directory disappeared. I found the lock with 'Process Explorer' and searched for 'Foxit Reader'. There were two locks for the same process, 'BrCtrlCntr.exe'.


  • 2
    You just made my morning. Thank you. – hwilbanks Sep 27 '13 at 11:59
  • 1
    Cool, I ran into this problem again when trying to upgrade Oracle Virtual Box. Luckily I wrote it down! Also 'handle' by SysInternals is good for finding the locked file handle. – Chloe Mar 21 '14 at 18:17

Your Answer


By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.