My Chrome Omnibox intermittently interrupts my typing, performs google instant search, and moves the focus off of the omnibox, preventing me from continuing to type. Is there a setting that I can change to prevent focus from shifting and my typing from being interrupted?

Example, if I start typing 'face the ', the omnibox autocomplete shows 'facebook.com' and shows instant search normally until I type the 't', then autocomplete shows 'face the nation' and acts as if I had pressed Enter. The Omnibox changes to show a google search URL and focus goes away, preventing me from finishing typing.

Any suggestions to prevent this behavior?

  • I just noticed this happening today to me as well
    – Keltari
    Jun 6, 2013 at 20:19
  • The same thing is happening to me on my Chrome Browser Version 27.0.1453.110 m IT'S EXTREMELY ANNOYING! Anyone know a way to revert versions?
    – SpYk3HH
    Jun 7, 2013 at 11:52

1 Answer 1


If you guys are on Chrome v28.0.xxxx (type about:version in omnibox), it appears to be a bug. My version 27.0.xxxx doesn't do that.


Edit: Some users experiencing it on version 27.0.xxx, so it's not that! Proposed fix/workaround from link above:

If you're still seeing the issue, and you haven't already done so, follow these steps:

  1. Click the Settings menu in Chrome (three stacked horizontal lines).
  2. Click Settings from the menu.
  3. Under the "Search" section, make sure that "Enable Instant for faster searching (omnibox input may be logged)" is unchecked.
  • I'm on Version 27.0.1453.110 m and it does it to me. And I don't wanna undo the instant search, it was a good feature as it would jump to sites before and sometimes i'd wanna stop typing, but this is just annoying!
    – SpYk3HH
    Jun 7, 2013 at 11:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.