4

I'm having a peculiar problem. There is no sound coming from my external speakers. I have an Asus EeePC 1215B with an external set of speakers. And while the onboard speakers of my laptop work perfectly well, and while windows 7 recognizes it when I plug in the analog 3.5mm jack to the external speakers, no sound comes out.

I know it's not a hardware problem. I have a dual-boot system, and this EXACT hardware setup works perfectly fine under my linux distro.

I have checked and double-checked all volume and mute settings. No mute is on, and volume is up (yes, also the physical volume button on my external speakers). As soon as I unplug the 3.5mm jack, my on-board speakers work fine. As soon as I plug it in, silence.

I have updated my audio drivers, both from microsoft and from the asus website. I've rolled back, upgraded again, and this didn't solve the problem.

Under playback devices, my speakers show up. They are set as default device (the other is my HDMI, which I don't ever use), and the green bar to the right actually lights up when sound is played. It just never leaves the speakers.

Again, Windows does recognize the external speakers. Realtek HD Audio Manager pops up whenever I plug it in, and the onboard speakers are muted (as they should be).

I would appreciate any and all help you can give me, since I'm out of ideas. If more information is needed, I'd be happy to provide it. Thanks in advance!

Forgot to mention: I don't get any error messages anywhere. Not in the playback devices, nor in the device manager. Nothing errors at all.


@Ariane: I've tried. I've uninstalled it from the device manager with the speakers plugged out, then installed the Realtek HD Audio driver from the asus website (version 6.0.1.6293). After a restart, Windows informed me (in the lower right) that it was installing an audio driver. After that, no change in the behaviour (on-board speakers work fine, plugging in my external ones silences everything).

@CarlB: No, the only tabs I see in the Realtek HD Audio Manager (I hope that's what you mean, I cannot find anything literally named "Realtek options") are the "Speakers" and the "Microphone" tabs.

The Realtek HD Audio Manager does pop up when I plug in the 3.5mm jack, and allows me to select whether they are headphones or speakers. Both options don't work.

  • Try reinstalling the driver completely, with the speakers unplugged, and without ever booting into Linux (just in case there would be an OS conflict) – Ariane Jun 7 '13 at 22:23
  • Do you see an "HD audio 2nd output" tab from the Realtek options? – Carl B Jun 8 '13 at 4:09
  • We'll merge your accounts so you will be able to edit and respond again. Hold tight. – slhck Jun 8 '13 at 12:38
  • Thanks slhck, much easier this way. And sorry for the inconvenience. – IceRabbit Jun 8 '13 at 16:47
  • Every single thing you said is exactly the same as the issue I'm having with my Asus U36SG... If I ever find a way to fix it I'll reply here :/ – igordcard Sep 3 '13 at 1:08
1

I think this is a popular problem in Windows 7. I had the same problem with a Dell laptop. Try this solution:

  1. After plugging in an external jack or headphone, go to Control Panel -> Sound.
  2. Disable the sound card.
  3. After a second enable it.
0

This is an old thread but it may be of some help to someone in the future. I have a toshiba laptop that gave me the same problem after I installed sparky linux as a dual boot with my windows 7. after the dual boot setup my onboard speakers worked just fine but plugging in my extrnal speakers nothing. Nada zip nothing but it worked fine in linux. Well not a hardware problem right! long story short after it worked sometime in windows and all the time in linux and after driving myself crazy with changing speaker phone jacks and messing with the hardware before finding the hardware had to be ok bec ause it worked in linux and messing with updating drivers reinstalling blah! blah! Blah! I discovered that if I cold booted the laptop SHUT DOWN!!!! not reboot and chose windows 7 in my grub then the speaker jack would pass signal to the external speakers but a reboot from linux into grub then into win 7 no

  • I can think of nothing that would explain this other than some kind of soundcard configuration is carried over and not dumped in a reboot as it is in a cold boot ! The external speaker jack works all the time going from grub to windows 7 from a cold boot but Never from a reboot from sparky to grub and into windows7.................Hope this helps someone Tux out !!!!!!!.........I Mean Peace Out!!! – Mark Horn Oct 31 '17 at 5:07

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.