I am having problems connecting from Motorola Razr HD phone to my Windows 7 PC's shared folders via ES File Manager. Until recently everything worked fine, I could see/copy files just fine. Not sure what changed, but now I cannot. I am getting either "server not found" or "SMB Service is off" etc.

enter image description here

Other Windows PCs on the same LAN can access shares on this Windows 7 PC just fine. Also the phone can see and access shares on WD WorldBook NAS device.

Any idea why the phone can no longer access Windows PC?

Any help is really appreciated.

  • Firewall? Is one active? – Canadian Luke Jun 9 '13 at 2:16
  • It is active, but it doesn't prevent other PCs from accessing the shares (I guess rules are in effect). Also turning it off has no effect on phone access. Funny thing when I do a LAN search in ES File Explorer - the IP of the Windows 7 PC is found, but I can do nothing with it. – Yuriy Galanter Jun 9 '13 at 2:18
  • are you putting in a username and password? – Frank Thomas Jun 9 '13 at 2:21
  • Yes I am, but still doesn't help. When I do the same for a share on NAS - it works fine. – Yuriy Galanter Jun 9 '13 at 2:23
  • 2
    It seems when I reboot the phone - it would work for a while, but then stop again. – Yuriy Galanter Jun 10 '13 at 13:28



Apparently you need to tell Windows that you want to use the machine as a file server and that it should allocate resources accordingly. Set the following registry key to ’1′:

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\LargeSystemCache

and set the following registry key to ’3′:


After making these changes and restarting, I haven’t seen this issue arise again. Fixed

| improve this answer | |
  • It might massively help to have a gist of the contents of that link in your answer - link only answers would be useless should they link you have linked to go down – Journeyman Geek May 19 '14 at 3:30
  • @JourneymanGeek I am aware. Posted from the phone to share as soon as I knew it worked. Will copypaste when I get to my laptop. – Yuriy Galanter May 19 '14 at 4:10
  • 1
    This helped in my case, however I only changed the LanmanServer size parameter as a LargeSystemCache appears to be quite risky without redundant power - technet.microsoft.com/en-us/library/cc784562%28v=ws.10%29.aspx – aland Jun 7 '15 at 19:37
  • 2
    Also used net stop server net start server rather than rebooting – aland Jun 7 '15 at 19:38
  • Link is broken now. Thanks for taking time to post the essentials. ... In my case the fix was to simply restart the "server" service, as per @aland comment, no registry change needed. – matt wilkie Jan 7 '16 at 6:19

I had an issue connecting with ESFE to a Win7 PC. This did the trick for me: Go to Network adapter configuration -> Tcp IP 4 settins -> WINS -> Enable NetBios over TCP/IP.

ESFE is looking for NetBios over tcp/ip because android probably doesn't natively run NetBios protocol.

Did you add or reinstall some network adapter?... That could cause the NetBios over TCP/IP to stop working because by default it is set to an ambiguous "Automatic" state.

| improve this answer | |
  • I'm also having the exact same problem but unfortunately your solution didn't help – waqaslam Nov 14 '14 at 15:12

To anyone out there, I was having the same issue with my HTC One M8 smartphone. Any wireless transfer app I downloaded would not work. I altered the TCP IP 4 settings as described above and now all my Android file transfer apps work GREAT!

Keep in mind that Windows7 DOES NOT allow you to view all files that you enable for sharing. Win7 ONLY allows you to view the "Public" files on a network. So, if you want to move files from your Win7 PC to your phone or visa versa, you have to copy the files on your Win7 PC and paste (duplicate them) into the desired public files.

I hope this helps, as I am sure many others are having this same problem attempting to use wireless transfer apps on their android smart phones.

| improve this answer | |

I have had the issue described above. The LAN (smb://) connection from ESFE worked the first time I tried it and then (the next day) problems... I could see the server (under LAN) and after waiting a long time it would show the shares, but would not access any files.

(Many hours and ill-advised actions later) I realized that that when I had had a successful connection the first time I also had a VPN running on the android device (torguard, if you're interested). I started torguard and... voila!

I don't know if this will help anyone else, but running a VPN works for me.

| improve this answer | |

I've recently had a problem with ALL of my Android devices not seeing my Win 7 shares after upgrading my home server from XP (on XP they all managed to see them fine using ES File on the devices, for years) - all clean installs and shares all defo setup correctly but no matter what i did all the android devices would either keep asking for a password or just keep spinning. After a few attempts at rebuilds using both 32/64bit versions of Win 7 and alternative android apps with varying success I tried a fresh install with NO MS updates installed - magically everything worked fine. Installed my BitDefender suite - still all OK for days. Then ran the MS updates until they were all done (200+ over a day or so) - shares all went dead again. So.... i was now pretty confident that in my case it was an MS update that stops it working on my machine.

I do have another win 7 machine though which is all MS patched up and it doesn't have the same issue and the shares on that all work fine.

I decided to try one last thing and installed and old 3com network card and bingo - all the shares started working again.... Server now all patched up and running like it was before with me able to brows the shares, stream etc. etc. with no issues at all - 5 days and counting.

For me it seemed that an updated network card driver was the most likely cause of my issues but it took weeks to find that out as the shares all worked fine with all my other win 7 machine attaching to the shares, it was just the androids that didn't work. My original nic was an onboard type.

So maybe worth grabbing a cheap nic card and installing it in your PC if you're having similar issues, or a cheap wifi dongle or something just to get the connection away from your current nic. Certainly worked for me.

Good luck...

| improve this answer | |
  • 1
    Welcome to Super User. Answers posted here need to be definitive to fit our Q&A format. Please edit yours to focus more on the specific steps needed to implement your solution. Too much detail makes it difficult for other users to put your answer to use. – I say Reinstate Monica Feb 17 '15 at 1:18

I had the same problem. It was with the router. The router was DLink Dsl 2750 u. In wireless basic settings > enable multicast isolation was enabled, I disabled it and I was able to access my pc. Check it if multicast isolation is enabled on your router. If it is disable it.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.