I've got problem while trying to open burned DVD-R, I even can't to make an iso image of it within dd - after making iso image, I've tried to mount them:

mount -t iso9660 /dev/cdrom /mnt -o loop=/dev/loop0 
mount: wrong fs type, bad option, bad superblock on /dev/loop0,
     missing codepage or helper program, or other error

     In some cases useful info is found in syslog - try
     dmesg | tail or so.

But when I open the DVD on the windows it works perfectly. I've tried to make an iso image there but get a lot of errors ( Alcohol 120% ).

Is it some sort of copy protection? If yes, how it works? I can easily open it in windows, but can't to make an iso image of it?

May be I'm using wrong software for making iso images, any suggestions?

The DVD contents software, not audio or movies.

  • Until you solve the problem of creating a valid ISO, you are not going to be able to mount it as a loopback device on Linux. – fpmurphy Jun 9 '13 at 11:38

I don't understand what you are trying to do, dev/cdrom is not an image, its the drive. What command did you use to make the image? Anyway, assuming you ran something like

dd if=/dev/cdrom of=/tmp/image.iso

You can then mount it like so:

mkdir foo
mount -t iso9660 -o loop /tmp/image.iso foo/

If this does not work, your image file probably has problems. Alternatives for creating the image are to use programs like brasero or k3b or mkisofs:

mount /dev/cdrom /media/cdrom
mkisofs -o /tmp/image.iso -graft-points -rational-rock -full-iso9660-filenames -iso-level 2 -r -J /media/cdrom
| improve this answer | |

Make sure your DVD uses a ISO9660 filesystem:

file -s /dev/cdrom

If your DVD is not using ISO9660, don't bother creating an ISO image out of it. That doesn't mean you can't create an image of it. If your DVD uses the UDF filesystem, you can create an UDF image and mount it, but not with the -t iso9660 option. The kernel is able to automatically detect the used filesystem, so you can simply try without any -t option and see if it works.

| improve this answer | |

This next looks wrong to me. My guess is that it would fail regardless of the DVD-R because the loop option is for mounting an image file (a plain file) whereas your /dev/cdrom is a device file.

mount -t iso9660 /dev/cdrom /mnt -o loop=/dev/loop0
| improve this answer | |

use nero and poweriso for burning. I am using it for several years without any issue.

If still that doesnt work, make sure that whether your ISO file is corrupted.

No issue of copyright.

If still have problem swap with another drive..

| improve this answer | |
  • 1
    The OP is using Linux. – terdon Jun 9 '13 at 13:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.