My server, which I built with some spare computer parts, does not power off after when I shut down from the OS. When I try to shut down, Windows closes all programs and goes through the shutdown routine as normal, and the screen turns off, but the fans continue to run until I hold down the power button on the case.

More importantly, though, because of this problem, the computer cannot truly restart. Windows shuts down, it goes into the not-quite-off state, and it stays there.

For a while, the power supply in the server only had a 20-pin connector (the motherboard has a 24-pin connector), and I thought that was the problem, but I have since replaced the power supply with one with a 24-pin connector, but nothing changed.

Sites on the Internet seemed to recommend trying a clean boot, which did not fix the problem.

I thought it was a hardware issue, but the fact that I can shut the power down completely with the case's power button seems to indicate that it might be a software issue.

EDIT: It is a software/configuration issue. I booted off a Ubuntu Live USB and was able to shut down and restart normally without any of the issues Windows has. I'd rather not reinstall Windows if that is an option.

EDIT 2: It restarts and shuts down properly from safe mode, but I have not been able to get it to shut down properly from a normal boot, regardless of how many startup items I disable. I tried removing the video card and a Wi-Fi card that never worked, but they also had no effect.

  • When you attempt to power off the computer using the OS, are the HDDs active, any blinking lights, does a mouse/keyboard movement start the computer? If not then it's most likely not a software related issue (at least on the Windows side) – cutrightjm Jun 10 '13 at 2:02
  • 1
    You might want to try some other OS, for example a Linux live-cd, to make sure it's not related to Windows. – KamikazeCZ Jun 10 '13 at 2:14
  • What is the OS? It sounds like the default action for the shutdown button in the Start Menu is Standby or Hibernate. – Davidw Jun 10 '13 at 2:32
  • It's Windows Server 2008 R2 x64. The default action is Logoff, but I make sure I click Shut down when I want to shut down. I'm preparing a Linux live-USB to try it out. – 0xFE Jun 10 '13 at 2:38
  • Ok, it's definitely not that, then, as Windows Server does not have any Sleep modes. Have you tried using the Command Line Shutdown command, or Powershell's Stop-Computer commandlet? – Davidw Jun 10 '13 at 2:40

Things you can try:

  • Check BIOS power settings and battery and if a BIOS update is available
  • Update all drivers (for display see the card manufacturer website)
  • Turn off hibernation
  • Prevent devices from waking your computer. You can list all of them via this command line:
    powercfg -devicequery wake_armed
  • Turn off wake-on-lan
  • Disable taskbar auto-hide
  • Run powercfg -energy to diagnose power problems

For more advanced diagnosis tools, see the article Diagnose Shutdown Problems with Xbootmgr. With xbootmgr you could probably trace the source of your system shutdown issue.

  • +1, generally playing with power settings (changing between S2 and S3 in BIOS) helps with this behavior. I don't think two cases are ever the same though, good luck! – David Houde Jun 14 '13 at 9:33
  • 2
    @DavidHoude: For +1 one should also click the up-arrow. – harrymc Jun 14 '13 at 10:08
  • i knew i was forgetting something ;) – David Houde Jun 14 '13 at 11:16
  • Hibernation is off (it's running Windows Server 2008R2). I tried turned off WoL, which were the only two devices in powercfg -devicequery wake_armed. powercfg -energy reported some issues, but they were mostly with timers and high CPU usage, nothing that seemed to me like it would cause problems. I tried updating my bios, and the updater causes Windows to freeze. I didn't see any driver updates. – 0xFE Jun 15 '13 at 17:28
  • Does the problem happen if you boot in Safe mode? I understand it does happen with Clean boot, which I find somewhat unbelievable. Just before the problem arrived did you install anything or do Windows Update? If this happened recently enough, you might try rolling back to a previous system restore point. – harrymc Jun 15 '13 at 19:59

I had a similar problem within our corporate environment, in the end the fix was as simple as toggling the registry key that handles this windows function. The key you’re looking for is called “PowerdownAfterShutdown” located in

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

If it’s set to 1 change it to 0

If it’s set to 0 change it to 1

You will need to restart after this change, but the next time you Shutdown it should stay offline, if not reverse the change, restart and it should work from there.

  • 3
    Microsoft says here about PowerdownAfterShutdown : "Windows 2000 does not use this entry. The entry remains in the registry to support programs designed for Windows NT 4.0 and earlier". This is old. – harrymc Jun 14 '13 at 8:23
  • While i do admit that the solution sounds unlikely, it is worth a try. The system in my situation was Windows 7 Pro x86 – Nathan Kerr Jun 14 '13 at 13:01
  • In Windows 7 this entry doesn't exist in the registry, so I don't understand how you could have found it in your registry, unless you installed some old product that added it in. – harrymc Jun 14 '13 at 13:50
  • I actually had this entry in my registry and it was set to 0, but I switched it to 1, rebooted and then shut down again and it didn't seem to have any effect unfortunately. – 0xFE Jun 14 '13 at 22:19

I have also run iinto shutdown issues in the past with a server and it turned out it had to do with a teaming. I disabled my teamed network connection and my issues went away. This was on Win2008 R2 and on an intel board with Intel nic. Sorry dont recall the model but it was from about 3 years ago. Might be worth a look.


You say you've disabled startup items, but what about services? Those are listed separately from startup items in Windows. They're also likely to be lower-level items that would be the last to shutdown (maybe even after your monitor). And since the fans are still running, that hints that the CPU may still be executing or waiting on something.

Here's how you can do it:

  1. Go to Control Panel -> Administrative Tools -> Services and find a service that's running and is also "Automatic". Right click and stop it, and also set its startup behavior to "Manual" (so it doesn't come back if you need to reboot while solving this problem).
  2. Try to restart.
  3. If it doesn't work, force reboot (i.e. hold the power button as you've been doing).
  4. Once you've rebooted, go to step 1 again. Keep doing this until you can restart properly or have gone through all the services. If this doesn't work, at least you'll have narrowed it down a lot.

There are lots of online resources to help you understand what each service does and which are/aren't essential, e.g. http://www.techrepublic.com/blog/10things/10-windows-7-services-you-may-not-need/3146


I finally gave in and reinstalled Windows, this time upgrading to Windows Server 2012. I had no problems until I installed Hyper-V. It refused to boot up with the hypervisor. I went back and reinstalled Windows Server 2008R2, and found that initially, it too had no problems rebooting. It wasn't until I installed Hyper-V that it had problems shutting down. I think my chipset has a bug in the virtualization implementation, and the motherboard is old enough that there is no hope for a BIOS update.

This also explains why diagnosing the issue was such a challenge. Hyper-V runs very close to the metal, so many of the tools didn't seem to report a problem. Also, the hypervisor is disabled in safe mode, which explains that as well.


I ran into this issue too and discovered that Windows 7/8 wants the SATA settings in the BIOS set to RAID or AHCI and not ATA. Saw similar hang on restart issue but would power down OK. Also no "Windows failed to shutdown properly" errors when it came back up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.