-1

I'm having a problem with my system. I recently just built a computer with the following specs:

Intel Core i7 2.66 ghz 8mb Cache
Gigabite GA-EX58-UD3R X58
6GB RAM
NVIDIA GeForce GTX-285 1GB

I'm using Windows 7 RC 32-bit for my operating system.

My RAM states that I have almost 3GB memory, so I'm assuming that the 3GB from the RAM is transferred to VRAM.

I have tried several methods I could find on google, including re-installing the OS but its still doesn't work.

1). Why I can't use more than 3Gb of my memory?

2). How can I diagnose the actual amount of memory available to my system? (to investigate faulty memory)

3). What is the solution for this?

1
  • I have a Notebook/Windows 7/8 GB RAM, 2 GB of these is free. You could use memtest or memtest86 to check the RAM. – ott-- Jun 10 '13 at 10:59
2

The solution to this is installing a 64-bit operating system.

Hence, a processor with 32-bit memory addresses can directly access 4 GiB of byte-addressable memory. Wikipedia

While your processor is absolutely capable of adressing all the memory, a (standard) 32-Bit OS installation will only "see" ~3.3 gb of said memory.

1

Not the answer you're looking for? Browse other questions tagged or ask your own question.