I have a one year old Mac Book Pro that I am trying to get RHEL 5.4 installed on via bootcamp. No matter what I do I can't get the installer to boot. I have tried multiple DVD's and even verified the install works on a new Mac Book Pro. Most of the time the installer simply locks up.

I usually use Linux text with all-generic-ide on the boot line.

I removed the ide parameter and I just used linux text. The results I get are that a bunch of kernel messages appear then the background turns blue and a thin text box pops up saying its loading ata..... something it disappears too fast for me to read. Then the machine freezes. I pressed the alt function keys to see if I could look at the system log, here is what it says:

Alt-f3 says "trying to mount CD device hda" Alt-f4 says status error: hda: lastFailedSense Hda: Failed opcode was: unknown Hda: Lost interrupt Hda: Drive not ready for command Ide-cd: command 0x3 timed out

Above this junk it looks like it found the partition because it knew it was 20 GB and listed as /dev/sda3. I think it has something to do with the CD drive, is that possible?

Thanks again for the support.

PS I posted in the apple support forums ( Apple.com > Support > Discussions > Boot Camp > Installation and Storage) and didn't get an answer.

1 Answer 1


I pretty much followed this one when I first installed Linux on my MacBookPro (now a 1,5+ year old). The two big obstacles, as I remember it, were that it uses the UUID partition table and that I for some reason still can't get the machine to boot a 64-bit linux.

Edit: I see now that he has a link to a bootcamp version of the article as well. I haven't tried that (didn't have a windows CD when doing it).


You must log in to answer this question.