I have a Windows 8 machine with an AMD APU attached to my Home Theater system through HDMI (HDMI routes through a Home Theater AMP, then into the TV).

Here's my problem, Whenever the display is interrupted, usually by the TV being turned off or into powersave mode, the audio device lists as "Disconnected" in windows audio devices and I cant get it to re-recognize that the HDMI audio is, in fact, plugged in.

The only solution I have found so far is to restart the machine, which will then recognize the device without any problems, until the next time the TV turns off and the problem once again resurfaces.

Has anyone else seen this phenomenon? I have no idea if its the GPU, the HDMI interface, the AMP, or even the TV itself, as there really isn't much a way to tell...

  • I would blame the AMP for not properly handling the powersave codes. It is probably blindly passing on the "power off" code from the TV to the graphics card, which assumes nothing is listening on the HDMI cable anymore. That said, I'm not sure if that's something that can be handled correctly due to encryption. Jun 10 '13 at 19:20
  • Hard part is getting to pass it back again once the TV turns back on again. it passes the video power on code, just not the audio. Jun 10 '13 at 19:34

This problem in Windows is not new to version 8.

I suggest to create a new power plan in Control Panel -> Hardware and Sound -> Power Options -> Create power plan, call it for example HDMI Audio, and set the new power plan to disallow the monitors sleeping.

Whenever you play audio, change the power plan to HDMI Audio and put it back to Balanced afterwards (or whatever is your normal power plan).

You could create desktop shortcuts to to do this with the click of a button, using Powercfg.exe.

First list all your power plans by name and GUID :

powercfg.exe -l

This will get you the GUID of HDMI Audio as well as of Balanced, so you can switch to any one of them using the command :

powercfg.exe -s GUID

You might need to define these shortcuts as to be Run as Administrator.


There is a very long thread on this problem, starting in january 2010 :
Disable 'Monitor Off' detection, how?

It is worthwhile going through the entire thread, for there are some solutions mentioned for specific video cards.

The one solution that more than one person found to work, was disconnecting pin 19 of the HDMI cable (you might consider buying a cheap cable for testing) :


  • I thought like you in the first place, but the problem occurs when the TV goes to power saving mode, not the computer.
    – matan129
    Jul 2 '13 at 20:33
  • @matan129: The TVs I know don't have a power save mode, I believe this is controlled externally to the TV.
    – harrymc
    Jul 3 '13 at 5:08
  • I'm having this problem even when i power off the TV. I don't like leaving my TV on when im not using it. Jul 3 '13 at 23:49
  • (1) Please specify your computer model and that of the video and audio devices (in Device Manager), also the chipset if you know it. (2) Try deleting the audio device and rebooting. (3) Does this problem persist if you restart the video play program? (4) Is your power plan on High performance?
    – harrymc
    Jul 4 '13 at 6:59
  • (5) What happens if you unplug and replug the HDMI cable from the computer. Please answer.
    – harrymc
    Jul 4 '13 at 19:20

I have the same problem. Although is not a complete solution, at least you don't have to reboot. Create a bat file that contains:

net stop Audiosrv  
net start Audiosrv

and run it as administrator every time the sound vanishes.


I experienced this same issue and I came up with a few different solutions.

  1. Disabled the Power Saving on the TV so that the HDMI did not disconnect

  2. Used my onboard optical to carry the sound

I ended up going with the second option, but you could change your power savings mode on the TV and on the computer to not turn off the monitor after a set amount of time.

  • Did this resolve the problem for if you manually shut off the TV as well? For me, it loses audio when I turn off the TV (i.e. when I'm done watching TV for the night). Seems like a pain to have to leave my TV on 100% of the time, just so i dont have to reboot it everyday. Jul 3 '13 at 23:48
  • I don't want to use optical to carry the sound as optical does not deliver a 7.1 signal. at current my only option to deliver the full 7.1 audio is over HDMI. Jul 3 '13 at 23:53

When the TV is in power saving mode the connection with the HDMI interface stops (and of course when the TV is turned off). Probably Windows isn't configured to deal with such situation of sudden disconnection.

But, if so, what changes when you restart your computer? Why does it work then? My guess is that there is a service which needs to be restarted after you turn on the TV again. It's probably one of the AMD's drivers, but it's also possible to be one of MS's.

First of all: try to update your drivers

You can also try disabling the TV power saving mode or connecting some other sort of cable, not HDMI Try to check if this prolem occurs with VGA for example.

If driver updating does not help, try: Go to Run and type services.msc. A Window with all the computer services should appear.

  1. First, click on the head of the status row in order to put all the strated services up, because they should be the source of your problem.
  2. If there are any AMD services running which are related - try to restart them one by one until the problem is solved - the TV will appear as connected again (since I don't have AMD APU I can't check it myself).
  3. If none of the AMD services affect the problem, do step 2 on these services:
    • Human Interface Device Access
    • Multimedia Class Scheduler
    • Plug and Play
    • Quality Windows Audio Video Experience
    • Windows Media Player Network Sharing Service
    • Windows Media Center Receiver Service
    • Windows Media Center Scheduler Service

If you are able to determine which service is causing the problem comment below and I will think about something to permanently fix this.

Edit: From what I see from searching for "HDMI service windows" - the related service are intel's (regarding second generation processors - GPU built it, like the APU). But you have AMD hardware, so it makes even more sense that the service will be AMD's.

  • All my drivers are up to date, and all AMD related services are running normally. I found nothing in the event logs to indicate a problem with them. Jul 3 '13 at 23:49
  • the only thing that seems to change after reboot is that now the sound works again. When the sound is gone, I can still see the device in Playback Devices, and i can even send test tones out. Programs and music plays as if all systems are normal, but no actual sound is delivered to the Amplifier. I know this because the amplifier does not show any audio streams being passed to it. (when it functions normally it shows that sound is being passed at 24bit/192khz. when its not working the amp receives nothing.) Jul 3 '13 at 23:52

There is a little trick :

  1. Set your PC to sleep/energy saving mode and turn off your HDMI device

  2. Then wake up your PC turn on your HDMI device

The sound returns ;)


I know this is an old topic, but I found another workaround which works for me – and hopefully helps some of you too.

Restart the Windows Audio Service after your screen comes back from screensaver. Easiest way to do this is create a new shortcut and copy/paste the following text into the "Target" box

C:\WINDOWS\system32\schtasks.exe /run /tn elevated_restartaudio_D

Save your shortcut with some obvious name like maybe "Audio Restart".

  • For completeness, what should be in the "elevated_restartaudio_D" task?  Please do not respond in comments; edit your answer to make it clearer and more complete.
    – Scott
    Nov 2 '15 at 20:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.