Is there a terminal command in Mac OS X to disable/enable the trackpad/mouse? I know that I can disable the trackpad of my MacBook Pro when an external mouse is connected. But is this also possible without a peripherial connected?

  • Checkout @SleeplessRazi answer. That works for newer macOS including Sierra. Feb 23 '17 at 11:11

You would have to unload the kexts, which would remove support for the hardware until reloaded. I don't really recommend this.


sudo kextunload /System/Library/Extensions/AppleUSBTopCase.kext/Contents/PlugIns/AppleUSBTrackpad.kext


sudo kextload /System/Library/Extensions/AppleUSBTopCase.kext/Contents/PlugIns/AppleUSBTrackpad.kext
  • Does not work on 10.14. Throws Unable to determine realpath for /System/Library/Extensions/AppleUSBTopCase.kext/Contents/PlugIns/AppleUSBTrackpad.kext - failing. Can't create /System/Library/Extensions/AppleUSBTopCase.kext/Contents/PlugIns/AppleUSBTrackpad.kext. Jun 10 '19 at 13:57
  • Welp, apple does like to change things a lot between major version numbers. It was only a matter of time for this to become obsolete.
    – demure
    Jun 10 '19 at 21:34

I tried this in OS X 10.9.5

sudo kextunload /System/Library/Extensions/AppleUSBMultitouch.kext

it gives error "(kernel) Can't unload kext com.apple.driver.AppleUSBMultitouch; classes have instances" but it disables the Trackpad successfully.

Then after

sudo kextload /System/Library/Extensions/AppleUSBMultitouch.kext

it enables the Trackpad again.

  • 2
    FYI on 10.11.3 El Capitan I found this to disable the entire keyboard as well.
    – sming
    Feb 24 '16 at 22:51
  • @sming same here. what's the solution? Jul 25 '16 at 0:17
  • Using Sierra it works. Only disables Trackpad and not Keyboard. Feb 20 '17 at 15:55
  • I just tried this on 10.12.5 and it disabled the trackpad... and then caused a kernel panic.
    – nvahalik
    Jun 20 '17 at 19:00
  • Same kernel panic for me :( Jul 5 '17 at 8:59

In OS X 10.9 I tried

sudo kextunload /System/Library/Extensions/AppleUSBMultitouch.kext/

to disable a temperamental trackpad, but that gave an error and didn't do anything. But moving the extension elsewhere, i.e.

sudo mv /System/Library/Extensions/AppleUSBMultitouch.kext ~

and restarting did the trick—though for some reason it also disabled the internal keyboard (except for the power button).

FYI, Apple menu > About This Mac > More Info... > System Report... > Extensions (under Software) shows which kernel extensions are currently active.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy