37

I'm creating a Visio 2013 diagram, and when I add a background colour to the diagram, the text of the arrow looks like this:

black arrow (on blue background) with black text (on a white rectangular background) overlaid

I want to remove that white text background, but I can't find how...

I found the solution for Visio 2007 in this post, but it doesn't work for Visio 2013, since there's no “Format” → “Text” menu. There's a “Format Shape” menu instead, but it contains only “Fill” and “Line”, no “Text”!

I tried to change the “Line” colour, and it changes the colour of the line (now is black), but I tried to change the “Fill” colour and it doen't change anything!

63

It's in the extended Font/Text properties, under Text Block:

enter image description here

Image source

  • 4
    Thanks very much! I searched evrywhere but there... they couldn't hide it better :) – MikO Jun 11 '13 at 16:42
  • 1
    Yeah I find in general with the ribbon interface(s), if you can't find it, it's buried under one of those little arrows. :) – Ƭᴇcʜιᴇ007 Jun 11 '13 at 17:24
  • 1
    I would never have found this on my own. Awesome, thanks! – willem Feb 5 '14 at 9:22
  • I wish Visio would put this where it obviously belongs (i.e. right clicking the text) – Mike Wise Mar 9 '18 at 11:51
  • 1
    If you're adjusting this using VBA, you can modify the connector object's shape sheet directly. With vsoConnector as a Visio.Shape, setting the background to transparent would be: vsoConnector.CellsSRC(visSectionObject, visRowText, visTxtBlkBkgnd).FormulaU = "0" – SmrtGrunt Oct 31 '18 at 17:39

protected by Community Jan 25 at 7:20

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.