4

Let's say I have some rows or columns that are hidden, and drag a selection across where those hidden values would normally be. Is there a way to prevent Microsoft Excel from copying those hidden cells?

I've found a workaround that sometimes works by pasting it all into Notepad, and then copying that, then pasting it into the spreadsheet I want to paste those values into, but it seems there should be a better way to do that. Unfortunately this workaround doesn't always work so well.

4

From Copy visible cells only:

If some cells, rows, or columns on your worksheet are not displayed, you have the option of copying all cells or only the visible cells. By default, Excel copies hidden or filtered cells in addition to visible cells. If this is not what you want, follow the steps in this article to copy visible cells only. For example, you can choose to copy only the displayed summary data on an outlined worksheet.

  • Select the cells that you want to copy.
  • On the Home tab, in the Editing group, click Find & Select, and then click Go To.
  • In the Go To dialog box, click Special.
  • Under Select, click Visible cells only, and then click OK.
  • On the Home tab, in the Clipboard group, click Copy.
  • Select the upper-left cell of the paste area.

    Tip: To move or copy a selection to a different worksheet or workbook, click another worksheet tab or switch to another workbook, and then select the upper-left cell of the paste area.

  • On the Home tab, in the Clipboard group, click Paste.

Notes

Excel pastes the copied data into consecutive rows or columns. If the paste area contains hidden rows or columns, you might need to unhide the paste area to see all of the copied cells.
If you click the arrow below Paste, you can choose from several paste options to apply to your selection.

6

I recently learned this nice shortcut from another SU user.

Select all cells as you usually do and then press

  1. Alt+; » Select only visible cells within your (or Alt+Shift+, depending on keyboard layout)
  2. Ctrl+C » Copy
  3. Ctrl+V » Paste
0

Okay, here is what I found. When using autofilters, only the filtered results get COPIED, but if you CUT the selection, both visible and unvisible cells are moved.

0

I tried a workaround. All rows are copied only when 1 option is selected in filter. Try using 2 values in filter (ie two values in the same column). To overcome the issue of unwanted data, I inserted a dummy row (and select my data and the dummy data). And after copying that i just remove the dummy data. Please reply for any clarification.

  • 1
    You’re answering the wrong question. This question isn’t about filtered data, it’s about hidden rows. – Scott Oct 18 '17 at 2:54
-2

Same problem, can't do with excel on Macbook. Solved simple by copy to another program (ect. Autocad) then copy from Cad to Excel.

  • The OP says he has tried that and does not want this workaround. – user477799 Apr 3 '17 at 7:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.