Installed a new GPU, and PC won't boot. Turn it on and:

  • No monitor signal at all (tried HDMI and VGA via DVI, on 2 working monitors).
  • CPU and GPU fans DO spin, but
  • No system beeps, no sounds from drives (they might make a small noise in the first 1 second or so, but there's definitely no OS loading or anything like that)
  • If hit "power off" button it turns off immediately (no holding down for 3 seconds like usual)

If I put my old HD 5670 GPU back in, everything works fine.

But (plot twist!) card is not totally dead. My friend put it in his PC, and it works fine (he even played a game for 15 minutes, no issues). He has a Corsair TX850 850W and a Gigabyte MB.

So my main theory is: the GPU isn't getting enough power from the PSU. But is it:

  • Bad PSU? Seems unlikely, since it works fine with the other GPU. Also, the PSU Is brand new and 550W (single 42A/504W 12V rail). Overkill for this GPU. Corsair is a decent brand, but maybe just mine is faulty?

  • Bad GPU? Could it be drawing more power than it should be, somehow, or something? Supposedly HD 7790 needs only 21A/75W on the 12v rail, though this one is factory overclocked a bit... but should that triple the power requirement?

  • Something else? Could there be a motherboard incompatibility somehow? Both MB and GPU are less than a year old and PCI Express 3.0 x16.

Things I've tried:

  • Re-seating the video card
  • Testing PC with old GPU (works fine, same PCIe slot).
  • Checked AMD's stated amp/watt requirements of a 7790 and my PSU (see above). My PSU can output twice the amps (single rail) and 5x the Wattage a 7790 needs.

Here are the full specs:

Gigabyte HD 7790 1GB OC GPU
Corsair VS550 550W PSU
AsRock H61M U3S3 motherboard
500GB SATA HDD (2007-ish)
blu-ray drive (new)
PCI 802.11g card

Edit: Motherboard BIOS Update seems to have fixed it. (If anyone has same problem and it doesn't work, comment here).

| improve this question | | | | |
  • Have you tried re-seating the card in a slot? – gronostaj Jun 13 '13 at 7:40
  • 1
    I think +1 for already putting the card into another machine, but is it practical to use your friends PSU to test (if it is more powerful)? If you now remove the GPU, does the PC then boot up as expected? 550W may be enough, may be not! Depends on everything else you have plugged in etc. Was the GPU overclocked as stock or did you do this? – Dave Jun 13 '13 at 7:43
  • @gronostaj yeah, a few times, seems firmly in place. Only one PCIe slot, and that slot works fine with my old GPU. – MGOwen Jun 13 '13 at 7:54
  • @DaveRook Yes it boots. 550W is 200-300W more than the components need, checking online power estimation tools. GPU overclock is stock. I'll try to find a powerful PSU to plug in... – MGOwen Jun 13 '13 at 8:20

I've seen that problem happen before with a brand new graphics card with 2GB of RAM. The graphics card worked fine on one computer, and the other computer wouldn't start with the new graphics card installed in it. The fans would spin, but there was no monitor signal at all, neither for VGA nor HDMI.

The first thing I would check to troubleshoot your problem is your ASRock motherboard1. Maybe your motherboard isn't delivering enough power to your graphics card. A graphics card with two large fans like yours would require more power than usual when the system is booting.

1 Motherboard BIOS update fixed it.

| improve this answer | | | | |
  • I've updated the motherboard BIOS and will try it again... – MGOwen Jun 13 '13 at 12:44
  • The bios release notes said it had VGA bios updates or something, maybe that will help... – MGOwen Jun 14 '13 at 10:28
  • The only other thing I can think of is to write down all your old BIOS settings and reset the BIOS settings to their factory defaults (either click the "Clear CMOS" button if your motherboard has one or check "Reset BIOS settings to factory defaults" in the BIOS setup utility), and then try booting with the default BIOS settings. – karel Jun 14 '13 at 10:46
  • Updated the Motherboard BIOS, and it works now! Thanks! (I also tried it in a friends machine with a Gigabyte mobo and an 800W Corsair PSU, so it's possible that had some effect somehow, if someone else is having this same issue, but 99% sure it was the BIOS update) – MGOwen Jun 22 '13 at 1:32
  • 2
    My symptoms were the same. My PC config: MSI h61-p20 g3; Intel G850; 8GB DDR3; SSD+HDD; HIS7790OC; Chieftec 450W 80plus. BIOS update helped me too. Thank you! – Alex Antonov Oct 21 '13 at 9:08

I also had a similar issue.

It turns out I did not have the PCI-E power plug inserted into the Radeon card itself. Very simple fix.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.