20

I am unable to launch the Cisco VPN Client successfully. When the splash screen reaches the step labeled "Opening cert store", it simply hangs and goes unresponsive.

Picture of the "Opening cert store" step

In the event viewer (eventvwr.exe) I found a warning stating:

The application (Cisco AnyConnect VPN Client, from vendor Cisco) has the following problem: To function properly, Cisco AnyConnect VPN Client must be reinstalled after you upgrade Windows.

Nothing else seemed to be amiss. Any good ideas on how to debug this further or solve the issue?

33
+100

I finally found out what was causing this. A single answer by Chad Roeder on the Cisco support forums had the right solution:

  1. Open Microsoft Management Console (type mmc in Run or search).
  2. Add Snap-in "Certificates" (File -> Add/Remove Snap-in... -> [find and add "Certificates] -> Choose "My User account" -> OK)
  3. Go to the folder Personal/Certificates
  4. Remove any unwanted certificates (for me it was certificates added by Fiddler to enable SSL traffic debugging)
  5. Consider repeating step 2-4 but using "Computer Account" instead of "My User account".

I hope this helps making the solution more visible in online searches. :)

To mitigate this issue within Fiddler, either use the Fiddler CertMaker Extension (which does not add the certificates to your store in the first place) or use the QuickExec box below the Fiddler Web Sessions list to run the following command:

prefs set fiddler.CertMaker.CleanupServerCertsOnExit True
  • @EricLaw Awesome addition. Other people might have issues with other applications than Fiddler, so I'll leave it with both solutions here. Yours is surely helpful to make sure Fiddler stays useful for me. :) – Johny Skovdal Jun 13 '13 at 18:18
  • 1
    Also, the Fiddler certs are added to the Current User store ("My current user" as you add the snap-in in mmc). I got confused because I couldn't find them in the "Computer account" store. – Dan Mangiarelli Nov 19 '14 at 18:35
  • 1
    @DanMangiarelli: Thank you, updated the answer with the info. :) – Johny Skovdal Dec 2 '14 at 6:39
  • 1
    Asked and answered in the same minute - that means you only made this to share this information. You've pretty much saved my life. – corsiKa Mar 22 '15 at 22:59
0

Add Cisco certificate to My User account Certificates, worked for me.

CN = Cisco Systems, Inc.
OU = Endpoint Security
OU = Digital ID Class 3 - Microsoft Software Validation v2
O = Cisco Systems, Inc.
L = Boxborough
S = Massachusetts
C = US
  • 1
    Did that give you the same error of the dialog stalling at opening cert store beforehand? Sounds like a different problem to begin with? :) – Johny Skovdal Mar 20 '18 at 9:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.