(No actual programming involved, hence posting here instead of SO.)

A couple of days ago I installed Visual Studio 2010 beta 2 on freshly installed Windows 7 box. This has never had VS2010 beta 1 installed.

I've just checked out my code from Subversion (which was last run in VS2010 beta 1), and tried double-clicking on the solution file - nothing happens. The icon shows the VS2010 infinity band, but hovering over it shows Version: (unrecognised version).

I can open up the solution manually, but why does Explorer not know about the version? (Which I assume is why it won't open up via double-clicking.)

EDIT: I've just checked against a solution created directly in Visual Studio 2010 - and that one works! I've had a look in the files themselves, and I can't see any obvious differences... will keep experimenting.

  • Based on your edit, does this happen when you open a project edited in VS 2008 last? I am wondering if it is not a problem with the .sln file specifically in VS 2010 B1 or later? – BinaryMisfit Oct 26 '09 at 10:12
  • @Diago: See my answer. The problem was a change in format between beta 1 and beta 2, I believe... – Jon Skeet Oct 26 '09 at 10:14

EDIT: I've now blogged about this for the sake of greater exposure.

Got it!

After opening the solution manually, I added a new project (just to provoke a change) and saved the solution. There was a change to the solution file after all - I just wasn't looking carefully:

Before (broken):

Microsoft Visual Studio Solution File, Format Version 11.00
# Visual Studio 10

After (working):

Microsoft Visual Studio Solution File, Format Version 11.00
# Visual Studio 2010

So basically, the key is to change "10" to "2010" in the second line. If I still had beta 1 installed I could confirm that this really is a change, and not just me having manually mucked around with the solution file before, of course...

  • 1
    I can confirm. Still had B1 on another machine. – BinaryMisfit Oct 26 '09 at 10:19
  • Excellent. Worth a blog post, do you think? – Jon Skeet Oct 26 '09 at 10:24
  • Why not? Your blog needs a bit more activity :) – alex Oct 26 '09 at 10:37
  • @Jon. Agreed. You will probably beat me to it but I will put one up tonight. – BinaryMisfit Oct 26 '09 at 13:18
  • @Diago - I blogged about it soon after posting the answer actually. msmvps.com/blogs/jon_skeet/archive/2009/10/26/… – Jon Skeet Oct 26 '09 at 18:17

As you noted, there is error (or change - however you look at it) in solution file. However, I took approach of opening each solution file using "Open with" menu, manually selecting Visual Studio 2010 and then just clicking save. This will update solution file.

  • I had the same issue on my Windows 7 laptop. I have VS 2010 Ultimate installed and double clicking the solution in windows explorer does not open an VS instance. Then I manually changed the "open with" from VS Version Selector to VS 2010 and it worked. – HashName Sep 15 '11 at 11:09

I am also convinced I saw this come past as a bug on the mailing list, but can't find it on Connect.

I would however confirm that the association is correct in Windows Explorer. I tested this on both my Windows 7 machines, using both TFS and SubVersion and it is working for me.

Once VS2010B2 is installed the .sln extension should be mapped to the Microsoft Visual Studio Version Selector application that takes care of the magic. It is possible that it may fail in certain configurations.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.