I have fast boot enabled so shutdown and subsequent boot takes very little time like it should however when I restart my PC, the subsequent boot time is enormous, sometimes 20 minutes+. It keeps showing the Windows logo for a very long time, then shows a blank screen for a very long time and finally shows my lock/login screen.

I have Windows 8 Pro US 64 bit Lenovo Ideapad Z580 with NVidia Optimus and Intel Graphics 4000 and 16 GB RAM.

Things I have already tried: Doing a clean boot with only essential services on and all startup items disabled. I don't think it has anything to do with start up items or system services.

  • Does this problem happen if you boot into safe mode? This really points to a service being started that holds everything up. – Ramhound Jun 14 '13 at 10:51
  • Happens even if I boot into safe mode. Seems to me it is a hardware issue. I guess the only thing to try is to remove hardware drivers or disable them and then try restarting. Will try disabling graphics first. My intuition says its nvidia that's keeping it from starting in a timely fashion. – Zain Ally Jun 14 '13 at 12:18
  • If you have a SSD device be sure to update the firmware for it. I would try getting rid of the drivers for both graphics card. This will boot you to basic resolution but will verify if its a display driver problem. – Ramhound Jun 14 '13 at 14:20
  • install WPT (social.technet.microsoft.com/wiki/contents/articles/…) and run this command: xbootmgr -trace rebootCycle -noPrepReboot -traceFlags BASE+CSWITCH+DRIVERS+POWER -resultPath C:\Temp zip the ETL file and upload it. I'll take a look at it. – magicandre1981 Jun 14 '13 at 17:27
  • I tried disabling the both graphics cards one by one and then disabling the sound card but none of those affected the restart times. They remain the same. I am installing the WPT now and will upload the ETL file for magicandre1981. – Zain Ally Jun 15 '13 at 14:07

ok, I also think you have HDD issues. I checked the traces and the high CPU usage is caused by the CI.dll (Code Integrity Module) which hosts SHA functions. Windows calls those SHA functions to verify the code integrity of System files.

enter image description here

This is during boot. During shutdown the same happens again. This causes other delays (GPO, Offline File cache, stopping Google Input helper at shutdown).

So download the diag tool for your Hitachi Travelstar 5K750 750GB and look if the tool detects any kinds of issues.

| improve this answer | |

It could very well be bad sectors on the HD, needing a lot of retries. Scan the entire disk with a tool like Seagate SeaTools (free, decent), HDD Regenerator (paid, thorough) or SpinRite (paid, extremely thorough), which will cause the SMART subsystem to reallocate bad (almost failing) sectors.

| improve this answer | |
  • HDD Regenerator only seems to have a free trial? – Richard Lucas Jun 18 '13 at 8:00

The answer to the question is in one of the Lenovo community forums about this laptop. Link:http://forums.lenovo.com/t5/IdeaPad-Y-U-V-Z-and-P-series/Z580-slow-boot-after-RAM-upgrade-w-Optimus-enabled/td-p/942065

Apparently, this laptop is not compatible with 16GB of RAM. Although it detects it fine but the performance is horrible.

I have disabled Optimus from the BIOS settings as one of the users says in the post. That worked like magic on my computer. The next thing I am going to try is to remove one of the RAM sticks and downgrade it to 8GB and see if it still remains as fast as it is now.

As I had mentioned previously, there was nothing wrong with my hard drive. I also ran memtest thorough tests and no errors were detected in my RAM chips.

Edit: Tried removing the RAM stick and enabled Optimus. That works too.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.